Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 1 | SUMMARY = "Checksumming Copy on Write Filesystem utilities" |
| 2 | DESCRIPTION = "Btrfs is a new copy on write filesystem for Linux aimed at \ |
| 3 | implementing advanced features while focusing on fault tolerance, repair and \ |
| 4 | easy administration. \ |
| 5 | This package contains utilities (mkfs, fsck, btrfsctl) used to work with \ |
| 6 | btrfs and an utility (btrfs-convert) to make a btrfs filesystem from an ext3." |
| 7 | |
| 8 | HOMEPAGE = "https://btrfs.wiki.kernel.org" |
| 9 | |
| 10 | LICENSE = "GPLv2" |
| 11 | LIC_FILES_CHKSUM = "file://COPYING;md5=fcb02dc552a041dee27e4b85c7396067" |
| 12 | SECTION = "base" |
| 13 | DEPENDS = "util-linux attr e2fsprogs lzo acl python3-setuptools-native" |
| 14 | DEPENDS_append_class-target = " udev" |
| 15 | RDEPENDS_${PN} = "libgcc" |
| 16 | |
Brad Bishop | 08902b0 | 2019-08-20 09:16:51 -0400 | [diff] [blame] | 17 | SRCREV = "9a85732d8beaae4b80cab98bb3355660389c1d36" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 18 | SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/kdave/btrfs-progs.git \ |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 19 | file://0001-Add-a-possibility-to-specify-where-python-modules-ar.patch \ |
| 20 | " |
| 21 | |
| 22 | inherit autotools-brokensep pkgconfig manpages distutils3-base |
| 23 | |
| 24 | CLEANBROKEN = "1" |
| 25 | |
| 26 | PACKAGECONFIG[manpages] = "--enable-documentation, --disable-documentation, asciidoc-native xmlto-native" |
Brad Bishop | c68388fc | 2019-08-26 01:33:31 -0400 | [diff] [blame^] | 27 | PACKAGECONFIG[zstd] = "--enable-zstd,--disable-zstd,zstd" |
| 28 | |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 29 | EXTRA_OECONF_append_libc-musl = " --disable-backtrace " |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 30 | EXTRA_PYTHON_CFLAGS = "${DEBUG_PREFIX_MAP}" |
| 31 | EXTRA_PYTHON_CFLAGS_class-native = "" |
| 32 | EXTRA_PYTHON_LDFLAGS = "${LDFLAGS}" |
| 33 | EXTRA_OEMAKE = "V=1 'EXTRA_PYTHON_CFLAGS=${EXTRA_PYTHON_CFLAGS}' 'EXTRA_PYTHON_LDFLAGS=${EXTRA_PYTHON_LDFLAGS}'" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 34 | |
| 35 | do_configure_prepend() { |
| 36 | # Upstream doesn't ship this and autoreconf won't install it as automake isn't used. |
| 37 | mkdir -p ${S}/config |
| 38 | cp -f $(automake --print-libdir)/install-sh ${S}/config/ |
| 39 | } |
| 40 | |
| 41 | S = "${WORKDIR}/git" |
| 42 | |
| 43 | do_install_append() { |
| 44 | oe_runmake 'DESTDIR=${D}' 'PYTHON_SITEPACKAGES_DIR=${PYTHON_SITEPACKAGES_DIR}' install_python |
| 45 | } |
| 46 | |
| 47 | BBCLASSEXTEND = "native" |