Brad Bishop | f3fd288 | 2019-06-21 08:06:37 -0400 | [diff] [blame] | 1 | SUMMARY = "Module::Build - Build and install Perl modules" |
| 2 | DESCRIPTION = "Many Perl distributions use a Build.PL file instead of a \ |
| 3 | Makefile.PL file to drive distribution configuration, build, test and \ |
| 4 | installation. Traditionally, Build.PL uses Module::Build as the underlying \ |
| 5 | build system. This module provides a simple, lightweight, drop-in replacement. \ |
| 6 | Whereas Module::Build has over 6,700 lines of code; this module has less than \ |
| 7 | 120, yet supports the features needed by most distributions." |
| 8 | |
| 9 | SECTION = "libs" |
| 10 | |
| 11 | HOMEPAGE = "https://metacpan.org/release/Module-Build" |
| 12 | |
| 13 | LICENSE = "Artistic-1.0 | GPL-1.0+" |
| 14 | LIC_FILES_CHKSUM = "file://README;beginline=949;endline=954;md5=624c06db56a2af4d70cf9edc29fcae1b" |
| 15 | |
| 16 | SRC_URI = "${CPAN_MIRROR}/authors/id/L/LE/LEONT/Module-Build-${PV}.tar.gz \ |
| 17 | file://run-ptest \ |
| 18 | " |
| 19 | SRC_URI[md5sum] = "1447d9e02e63f7a1643986789a8f1ba9" |
| 20 | SRC_URI[sha256sum] = "1fe491a6cda914b01bc8e592faa2b5404e9f35915ca15322f8f2a8d8f9008c18" |
| 21 | |
| 22 | S = "${WORKDIR}/Module-Build-${PV}" |
| 23 | |
| 24 | inherit cpan_build ptest-perl |
| 25 | |
| 26 | # From: |
| 27 | # https://github.com/rehsack/meta-cpan/blob/master/recipes-devel/module-build-perl/module-build-perl_0.4216.bb |
| 28 | # |
| 29 | do_patch_module_build () { |
| 30 | cd ${S} |
| 31 | sed -i -e 's,my $interpreter = $self->{properties}{perl};,my $interpreter = "${bindir}/perl";,g' lib/Module/Build/Base.pm |
| 32 | } |
| 33 | |
| 34 | do_patch[postfuncs] += "do_patch_module_build" |
| 35 | |
| 36 | do_install_ptest() { |
| 37 | cp -r ${B}/inc ${D}${PTEST_PATH} |
| 38 | cp -r ${B}/blib ${D}${PTEST_PATH} |
| 39 | chown -R root:root ${D}${PTEST_PATH} |
| 40 | } |
| 41 | |
| 42 | RDEPENDS_${PN} += " \ |
| 43 | perl-module-carp \ |
| 44 | perl-module-cpan \ |
| 45 | perl-module-config \ |
| 46 | perl-module-cwd \ |
| 47 | perl-module-data-dumper \ |
| 48 | perl-module-encode \ |
| 49 | perl-module-extutils-cbuilder \ |
| 50 | perl-module-extutils-command \ |
| 51 | perl-module-extutils-install \ |
| 52 | perl-module-extutils-installed \ |
| 53 | perl-module-extutils-mkbootstrap \ |
| 54 | perl-module-extutils-packlist \ |
| 55 | perl-module-extutils-parsexs \ |
| 56 | perl-module-file-basename \ |
| 57 | perl-module-file-compare \ |
| 58 | perl-module-file-copy \ |
| 59 | perl-module-file-find \ |
| 60 | perl-module-file-glob \ |
| 61 | perl-module-file-path \ |
| 62 | perl-module-file-spec \ |
| 63 | perl-module-file-spec-functions \ |
| 64 | perl-module-getopt-long \ |
| 65 | perl-module-metadata \ |
| 66 | perl-module-perl-ostype \ |
| 67 | perl-module-pod-man \ |
| 68 | perl-module-tap-harness \ |
| 69 | perl-module-text-abbrev \ |
| 70 | perl-module-text-parsewords \ |
| 71 | perl-module-utf8 \ |
| 72 | " |
| 73 | |
| 74 | RDEPENDS_${PN}-ptest += " \ |
| 75 | gcc \ |
| 76 | make \ |
| 77 | perl-module-blib \ |
| 78 | perl-module-file-temp \ |
| 79 | perl-module-lib \ |
| 80 | perl-module-perlio \ |
| 81 | perl-module-perlio-encoding \ |
| 82 | perl-module-pod-text \ |
| 83 | perl-module-tap-harness-env \ |
| 84 | perl-module-tap-parser \ |
| 85 | perl-module-tap-parser-scheduler \ |
| 86 | perl-module-test-harness \ |
| 87 | perl-module-test-more \ |
| 88 | " |
| 89 | |
| 90 | RPROVIDES_${PN} += "\ |
| 91 | libmodule-build-base-perl \ |
| 92 | libmodule-build-compat-perl \ |
| 93 | libmodule-build-config-perl \ |
| 94 | libmodule-build-cookbook-perl \ |
| 95 | libmodule-build-dumper-perl \ |
| 96 | libmodule-build-notes-perl \ |
| 97 | libmodule-build-ppmaker-perl \ |
| 98 | libmodule-build-platform-default-perl \ |
| 99 | libmodule-build-platform-unix-perl \ |
| 100 | libmodule-build-podparser-perl \ |
| 101 | " |
| 102 | |
| 103 | BBCLASSEXTEND = "native" |