Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | SUMMARY = "Lossless data compressor based on the LZMA algorithm" |
| 2 | HOMEPAGE = "http://lzip.nongnu.org/lzip.html" |
| 3 | SECTION = "console/utils" |
| 4 | LICENSE = "GPLv2+" |
| 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=76d6e300ffd8fb9d18bd9b136a9bba13 \ |
| 6 | file://decoder.cc;beginline=3;endline=16;md5=db09fe3f9573f94d0076f7f07959e6e1" |
| 7 | |
| 8 | SRC_URI = "${SAVANNAH_GNU_MIRROR}/lzip/lzip-${PV}.tar.gz" |
| 9 | SRC_URI[md5sum] = "c0061730d017ea593a09308edc547128" |
| 10 | SRC_URI[sha256sum] = "e48b5039d3164d670791f9c5dbaa832bf2df080cb1fbb4f33aa7b3300b670d8b" |
| 11 | |
| 12 | B = "${WORKDIR}/build" |
| 13 | do_configure[cleandirs] = "${B}" |
| 14 | |
| 15 | CONFIGUREOPTS = "\ |
| 16 | '--srcdir=${S}' \ |
| 17 | '--prefix=${prefix}' \ |
| 18 | '--exec-prefix=${exec_prefix}' \ |
| 19 | '--bindir=${bindir}' \ |
| 20 | '--datadir=${datadir}' \ |
| 21 | '--infodir=${infodir}' \ |
| 22 | '--sysconfdir=${sysconfdir}' \ |
| 23 | 'CXX=${CXX}' \ |
| 24 | 'CPPFLAGS=${CPPFLAGS}' \ |
| 25 | 'CXXFLAGS=${CXXFLAGS}' \ |
| 26 | 'LDFLAGS=${LDFLAGS}' \ |
| 27 | " |
| 28 | |
| 29 | do_configure () { |
| 30 | ${S}/configure ${CONFIGUREOPTS} |
| 31 | } |
| 32 | |
| 33 | do_install () { |
| 34 | oe_runmake 'DESTDIR=${D}' install |
| 35 | # Info dir listing isn't interesting at this point so remove it if it exists. |
| 36 | if [ -e "${D}${infodir}/dir" ]; then |
| 37 | rm -f ${D}${infodir}/dir |
| 38 | fi |
| 39 | } |
| 40 | |
| 41 | BBCLASSEXTEND = "native nativesdk" |