Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | SUMMARY = "Xfce4 Widget library and X Window System interaction" |
| 2 | SECTION = "x11/libs" |
| 3 | LICENSE = "GPLv2" |
| 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=252890d9eee26aab7b432e8b8a616475" |
| 5 | DEPENDS = "perl-native glib-2.0 gtk+ gtk+3 intltool-native libxfce4util xfconf xfce4-dev-tools virtual/libx11 libsm libice" |
| 6 | |
| 7 | inherit xfce autotools gettext gtk-doc gobject-introspection distro_features_check |
| 8 | |
| 9 | REQUIRED_DISTRO_FEATURES = "x11" |
| 10 | |
| 11 | SRC_URI += " \ |
| 12 | file://0001-libxfce4kbd-private-xfce4-keyboard-shortcuts.xml-fix.patch \ |
| 13 | " |
| 14 | SRC_URI[md5sum] = "b407cdab73ebd5c33c90db6bdb3ec5ff" |
| 15 | SRC_URI[sha256sum] = "d63fcdb8e5acb6f0d26075ea17d320dbfbec2058567cd67cb99824c7402a1f79" |
| 16 | |
| 17 | EXTRA_OECONF += "--with-vendor-info=${DISTRO}" |
| 18 | |
| 19 | PACKAGECONFIG ??= "" |
| 20 | PACKAGECONFIG[gladeui] = "--enable-gladeui,--disable-gladeui,glade3" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 21 | PACKAGECONFIG[gladeui2] = "--enable-gladeui2,--disable-gladeui2,glade" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 22 | PACKAGECONFIG[startup-notification] = "--enable-startup-notification,--disable-startup-notification,startup-notification" |
| 23 | |
| 24 | PACKAGES =+ "${PN}-gtk2 ${PN}-gtk3" |
| 25 | FILES_${PN}-gtk2 += "${libdir}/libxfce4ui-1.so.* ${libdir}/libxfce4kbd-private-2.so.*" |
| 26 | FILES_${PN}-gtk3 += "${libdir}/libxfce4ui-2.so.* ${libdir}/libxfce4kbd-private-3.so.*" |
| 27 | |
| 28 | PACKAGES += "${PN}-glade" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 29 | FILES_${PN}-glade = " \ |
| 30 | ${libdir}/glade \ |
| 31 | ${libdir}/glade3 \ |
| 32 | ${datadir}/glade \ |
| 33 | ${datadir}/glade3 \ |
| 34 | " |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 35 | |
| 36 | RDEPENDS_${PN}-gtk2 = "${PN}" |
| 37 | RDEPENDS_${PN}-gtk3 = "${PN}" |