Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 1 | SUMMARY = "Crypt Openssl RSA cpan module" |
| 2 | SECTION = "libs" |
| 3 | LICENSE = "Artistic-1.0 | GPL-1.0+" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=385c55653886acac3821999a3ccd17b3" |
| 5 | |
| 6 | SRC_URI = "http://www.cpan.org/modules/by-module/Crypt/Crypt-OpenSSL-RSA-${PV}.tar.gz " |
| 7 | |
| 8 | SRC_URI[md5sum] = "86217a5036fc63779c30420b5fd84129" |
| 9 | SRC_URI[sha256sum] = "5357f977464bb3a8184cf2d3341851a10d5515b4b2b0dfb88bf78995c0ded7be" |
| 10 | |
| 11 | DEPENDS += "openssl" |
| 12 | |
| 13 | RDEPENDS_${PN}="libcrypt-openssl-random-perl" |
| 14 | |
| 15 | EXTRA_CPANFLAGS = "INC='-I${STAGING_INCDIR}' LIBS='-L${STAGING_LIBDIR} -lssl -L${STAGING_DIR_TARGET}${base_libdir} -lcrypto'" |
| 16 | |
| 17 | S = "${WORKDIR}/Crypt-OpenSSL-RSA-${PV}" |
| 18 | |
| 19 | inherit cpan |
| 20 | |
| 21 | do_compile() { |
| 22 | export OTHERLDFLAGS='-Wl,-rpath' |
| 23 | cpan_do_compile |
| 24 | } |