Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 1 | SUMMARY = "HTML5 (plugin-free) web-based terminal emulator and SSH client" |
| 2 | LICENSE = "AGPL-3.0" |
| 3 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=834cbc6995db88433db17cdf8953a428" |
| 4 | HOMEPAGE = "http://liftoffsoftware.com/Products/GateOne" |
| 5 | |
| 6 | PV = "1.2+git${SRCPV}" |
| 7 | SRCREV = "f7a9be46cb90f57459ebd363d24702de0e651034" |
| 8 | SRC_URI = "git://github.com/liftoff/GateOne.git;branch=master \ |
| 9 | file://gateone-avahi.service \ |
| 10 | file://80oe.conf.in \ |
| 11 | file://gateone.service.in \ |
| 12 | file://gateone-init.in \ |
| 13 | " |
| 14 | |
| 15 | S = "${WORKDIR}/git" |
| 16 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 17 | inherit setuptools python-dir systemd update-rc.d |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 18 | |
| 19 | DISTUTILS_INSTALL_ARGS = "--root=${D} \ |
| 20 | --prefix=${prefix} \ |
| 21 | --install-lib=${PYTHON_SITEPACKAGES_DIR} \ |
| 22 | --install-data=${PYTHON_SITEPACKAGES_DIR} \ |
| 23 | --install-scripts=${bindir} \ |
| 24 | --skip_init_scripts" |
| 25 | |
| 26 | do_install_append() { |
| 27 | |
| 28 | # fix up hardcoded paths |
| 29 | for file in gateone.service gateone-init 80oe.conf; do |
| 30 | sed -e s:@bindir@:${bindir}:g \ |
| 31 | -e s:@localstate@:${localstatedir}:g \ |
| 32 | < ${WORKDIR}/$file.in \ |
| 33 | > ${WORKDIR}/$file |
| 34 | done |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 35 | |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 36 | install -d ${D}${systemd_unitdir}/system |
| 37 | install -m 0644 ${WORKDIR}/gateone.service ${D}${systemd_unitdir}/system |
| 38 | |
| 39 | install -d ${D}${sysconfdir}/init.d |
| 40 | install -m 0755 ${WORKDIR}/gateone-init ${D}${sysconfdir}/init.d/gateone |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 41 | |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 42 | install -m 0755 -d ${D}${sysconfdir}/avahi/services/ |
| 43 | install -m 0644 ${WORKDIR}/gateone-avahi.service ${D}${sysconfdir}/avahi/services/ |
| 44 | |
| 45 | install -m 0755 -d ${D}${sysconfdir}/gateone/conf.d/ |
| 46 | install -m 0644 ${WORKDIR}/80oe.conf ${D}${sysconfdir}/gateone/conf.d/80oe.conf |
| 47 | |
| 48 | install -d ${D}${localstatedir}/lib/gateone |
| 49 | } |
| 50 | |
| 51 | FILES_${PN} = "${localstatedir}/lib ${bindir} ${base_libdir} ${sysconfdir} ${PYTHON_SITEPACKAGES_DIR}" |
| 52 | RDEPENDS_${PN} = "mime-support \ |
| 53 | openssh-ssh \ |
| 54 | python-compression \ |
| 55 | python-contextlib \ |
| 56 | python-crypt \ |
| 57 | python-datetime \ |
| 58 | python-email \ |
| 59 | python-fcntl \ |
| 60 | python-futures \ |
| 61 | python-html \ |
| 62 | python-imaging \ |
| 63 | python-io \ |
| 64 | python-json \ |
| 65 | python-logging \ |
| 66 | python-misc \ |
| 67 | python-multiprocessing \ |
| 68 | python-netclient \ |
| 69 | python-pkgutil \ |
| 70 | python-pyopenssl \ |
| 71 | python-re \ |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 72 | python-setuptools \ |
| 73 | python-shell \ |
| 74 | python-simplejson \ |
| 75 | python-subprocess \ |
| 76 | python-syslog \ |
| 77 | python-terminal \ |
| 78 | python-textutils \ |
| 79 | python-tornado \ |
| 80 | python-unixadmin \ |
| 81 | python-xml \ |
| 82 | python-html5lib \ |
| 83 | bash \ |
| 84 | " |
| 85 | |
| 86 | SYSTEMD_SERVICE_${PN} = "gateone.service" |
| 87 | INITSCRIPT_NAME = "gateone" |