Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 1 | HOMEPAGE = "https://github.com/firehol/netdata/" |
| 2 | SUMMARY = "Real-time performance monitoring" |
| 3 | LICENSE = "GPLv3" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 4 | LIC_FILES_CHKSUM = "file://LICENSE.md;md5=95b49e9ea979a337578f13c2a3ab9535 \ |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 5 | file://COPYING;md5=d32239bcb673463ab874e80d47fae504 \ |
| 6 | " |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 7 | |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 8 | SRC_URI = "git://github.com/firehol/netdata.git;protocol=https \ |
| 9 | file://0001-makefile-Do-not-build-contrib-dir.patch \ |
| 10 | " |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 11 | SRCREV = "89ed309252981ddd50f697fde4fe93019cb3e652" |
| 12 | PV = "1.8.0+git${SRCPV}" |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 13 | |
| 14 | # patch to disable timeout because timeout are not available with actual version |
| 15 | # of core-utils |
| 16 | SRC_URI += "file://0001-Correct-Timeout-issue.patch" |
| 17 | |
| 18 | # default netdata.conf for netdata configuration |
| 19 | SRC_URI += "file://netdata.conf" |
| 20 | |
| 21 | # file for providing systemd service support |
| 22 | SRC_URI += "file://netdata.service" |
| 23 | |
| 24 | S = "${WORKDIR}/git" |
| 25 | |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 26 | DEPENDS += "zlib util-linux" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 27 | |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 28 | inherit pkgconfig autotools useradd systemd |
| 29 | |
| 30 | #systemd |
| 31 | SYSTEMD_PACKAGES = "${PN}" |
| 32 | SYSTEMD_SERVICE_${PN} = "netdata.service" |
| 33 | SYSTEMD_AUTO_ENABLE_${PN} = "enable" |
| 34 | |
| 35 | #User specific |
| 36 | USERADD_PACKAGES = "${PN}" |
| 37 | GROUPADD_PARAM_${PN} = "--system netdata" |
| 38 | |
| 39 | do_install_append() { |
| 40 | #set S UID for plugins |
| 41 | chmod 4755 ${D}${libexecdir}/netdata/plugins.d/apps.plugin |
| 42 | |
| 43 | if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then |
| 44 | # Install systemd unit files |
| 45 | install -d ${D}${systemd_unitdir}/system |
| 46 | install -m 0644 ${WORKDIR}/netdata.service ${D}${systemd_unitdir}/system |
| 47 | sed -i -e 's,@@datadir,${datadir_native},g' ${D}${systemd_unitdir}/system/netdata.service |
| 48 | fi |
| 49 | |
| 50 | # Install default netdata.conf |
| 51 | install -d ${D}${sysconfdir}/netdata |
| 52 | install -m 0644 ${WORKDIR}/netdata.conf ${D}${sysconfdir}/netdata/ |
| 53 | sed -i -e 's,@@sysconfdir,${sysconfdir},g' ${D}${sysconfdir}/netdata/netdata.conf |
| 54 | sed -i -e 's,@@libdir,${libexecdir},g' ${D}${sysconfdir}/netdata/netdata.conf |
| 55 | sed -i -e 's,@@datadir,${datadir},g' ${D}${sysconfdir}/netdata/netdata.conf |
| 56 | } |
| 57 | |
| 58 | FILES_${PN}-dbg += "${libexecdir}/netdata/plugins.d/.debug" |
| 59 | RDEPENDS_${PN} = "bash zlib" |