Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 1 | SUMMARY = "Utility library to parse, compare, simplify and normalize license expressions" |
| 2 | HOMEPAGE = "https://github.com/nexB/license-expression" |
| 3 | |
| 4 | LICENSE = "Apache-2.0" |
| 5 | LIC_FILES_CHKSUM = "file://apache-2.0.LICENSE;md5=e23fadd6ceef8c618fc1c65191d846fa" |
| 6 | |
Andrew Geissler | c87764f | 2020-06-27 00:16:32 -0500 | [diff] [blame^] | 7 | SRC_URI[md5sum] = "fd4cb295cc345be1071274cdbd81c969" |
| 8 | SRC_URI[sha256sum] = "7960e1dfdf20d127e75ead931476f2b5c7556df05b117a73880b22ade17d1abc" |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 9 | |
Andrew Geissler | c87764f | 2020-06-27 00:16:32 -0500 | [diff] [blame^] | 10 | inherit pypi ptest setuptools3 |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 11 | |
| 12 | RDEPENDS_${PN} += "\ |
| 13 | ${PYTHON_PN}-booleanpy \ |
| 14 | " |
| 15 | |
| 16 | BBCLASSEXTEND = "native nativesdk" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 17 | |
| 18 | SRC_URI += " \ |
| 19 | file://run-ptest \ |
| 20 | " |
| 21 | |
| 22 | RDEPENDS_${PN}-ptest += " \ |
| 23 | ${PYTHON_PN}-pytest \ |
| 24 | " |
| 25 | |
| 26 | do_install_ptest() { |
| 27 | install -d ${D}${PTEST_PATH}/tests |
| 28 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ |
| 29 | } |