Andrew Geissler | c87764f | 2020-06-27 00:16:32 -0500 | [diff] [blame^] | 1 | SUMMARY = "Parse strings using a specification based on the Python format() syntax" |
| 2 | HOMEPAGE = "https://github.com/r1chardj0n3s/parse" |
| 3 | LICENSE = "MIT" |
| 4 | LIC_FILES_CHKSUM = "file://parse.py;beginline=1325;endline=1345;md5=3d987b2e73881bbce768a80f9cdd23d9" |
| 5 | |
| 6 | SRC_URI[md5sum] = "a5aa82b2b8b4d733d227e3c99d7d01b4" |
| 7 | SRC_URI[sha256sum] = "a6d4e2c2f1fbde6717d28084a191a052950f758c0cbd83805357e6575c2b95c0" |
| 8 | |
| 9 | inherit pypi setuptools3 ptest |
| 10 | |
| 11 | RDEPENDS_${PN} += "\ |
| 12 | ${PYTHON_PN}-datetime \ |
| 13 | ${PYTHON_PN}-logging \ |
| 14 | " |
| 15 | |
| 16 | SRC_URI += " \ |
| 17 | file://run-ptest \ |
| 18 | " |
| 19 | |
| 20 | RDEPENDS_${PN}-ptest += " \ |
| 21 | ${PYTHON_PN}-pytest \ |
| 22 | " |
| 23 | |
| 24 | do_install_ptest() { |
| 25 | cp -f ${S}/test_parse.py ${D}${PTEST_PATH}/ |
| 26 | } |