blob: 7ced7d0174ba7f3bb075958755213948288cf76b [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "A toolkit to write, run and analyze benchmarks"
2DESCRIPTION = " \
3The Python pyperf module is a toolkit to write, run and analyze benchmarks. \
4Features: \
5 * Simple API to run reliable benchmarks \
6 * Automatically calibrate a benchmark for a time budget. \
7 * Spawn multiple worker processes. \
8 * Compute the mean and standard deviation. \
9 * Detect if a benchmark result seems unstable. \
10 * JSON format to store benchmark results. \
11 * Support multiple units: seconds, bytes and integer. \
12"
13LICENSE = "MIT"
14LIC_FILES_CHKSUM = "file://COPYING;md5=78bc2e6e87c8c61272937b879e6dc2f8"
15
Andrew Geisslerc87764f2020-06-27 00:16:32 -050016SRC_URI[md5sum] = "7f62d3f6fc5475138791d3d883fdf4cd"
17SRC_URI[sha256sum] = "2189fbc4af08d519f85468e70e32c902eab0f1341b2c41028b94b2832d3169a7"
Andrew Geissler82c905d2020-04-13 13:39:40 -050018
19DEPENDS += "${PYTHON_PN}-six-native"
20
21PYPI_PACKAGE = "pyperf"
22inherit pypi setuptools3
23
24RDEPENDS_${PN} += "${PYTHON_PN}-misc"