Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "An HTTP library implementation in C" |
Andrew Geissler | 90fd73c | 2021-03-05 15:25:55 -0600 | [diff] [blame] | 2 | DESCRIPTION = "libsoup is an HTTP client/server library for GNOME. It uses GObjects \ |
| 3 | and the glib main loop, to integrate well with GNOME applications." |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 4 | HOMEPAGE = "https://wiki.gnome.org/Projects/libsoup" |
| 5 | BUGTRACKER = "https://bugzilla.gnome.org/" |
| 6 | SECTION = "x11/gnome/libs" |
| 7 | LICENSE = "LGPLv2" |
| 8 | LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2" |
| 9 | |
| 10 | DEPENDS = "glib-2.0 glib-2.0-native libxml2 sqlite3 intltool-native libpsl" |
| 11 | |
| 12 | SHRT_VER = "${@d.getVar('PV').split('.')[0]}.${@d.getVar('PV').split('.')[1]}" |
| 13 | |
| 14 | SRC_URI = "${GNOME_MIRROR}/libsoup/${SHRT_VER}/libsoup-${PV}.tar.xz" |
Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 15 | SRC_URI[sha256sum] = "170c3f8446b0f65f8e4b93603349172b1085fb8917c181d10962f02bb85f5387" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 16 | |
| 17 | CVE_PRODUCT = "libsoup" |
| 18 | |
| 19 | S = "${WORKDIR}/libsoup-${PV}" |
| 20 | |
| 21 | inherit meson gettext pkgconfig upstream-version-is-even gobject-introspection gtk-doc |
| 22 | |
| 23 | GIR_MESON_ENABLE_FLAG = 'enabled' |
| 24 | GIR_MESON_DISABLE_FLAG = 'disabled' |
| 25 | |
| 26 | # libsoup-gnome is entirely deprecated and just stubs in 2.42 onwards. Disable by default. |
| 27 | PACKAGECONFIG ??= "" |
| 28 | PACKAGECONFIG[gnome] = "-Dgnome=true,-Dgnome=false" |
| 29 | PACKAGECONFIG[gssapi] = "-Dgssapi=enabled,-Dgssapi=disabled,krb5" |
| 30 | |
| 31 | EXTRA_OEMESON_append = " -Dvapi=disabled -Dtls_check=false" |
| 32 | |
| 33 | GTKDOC_MESON_OPTION = "gtk_doc" |
| 34 | |
| 35 | # When built without gnome support, libsoup-2.4 will contain only one shared lib |
| 36 | # and will therefore become subject to renaming by debian.bbclass. Prevent |
| 37 | # renaming in order to keep the package name consistent regardless of whether |
| 38 | # gnome support is enabled or disabled. |
| 39 | DEBIAN_NOAUTONAME_${PN} = "1" |
| 40 | |
| 41 | # glib-networking is needed for SSL, proxies, etc. |
| 42 | RRECOMMENDS_${PN} = "glib-networking" |
| 43 | |
Andrew Geissler | 5a43b43 | 2020-06-13 10:46:56 -0500 | [diff] [blame] | 44 | BBCLASSEXTEND = "native nativesdk" |