Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 1 | HOMEPAGE = "http://www.alumnit.ca/wiki/?WvDial" |
| 2 | DESCRIPTION = "WvDial is a program that makes it easy to connect your Linux workstation to the Internet." |
| 3 | |
| 4 | LICENSE = "LGPLv2" |
| 5 | LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=55ca817ccb7d5b5b66355690e9abc605" |
| 6 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 7 | inherit pkgconfig |
| 8 | |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 9 | DEPENDS = "wvstreams" |
| 10 | RDEPENDS_${PN} = "ppp" |
| 11 | |
| 12 | SRC_URI = "http://${BPN}.googlecode.com/files/${BP}.tar.bz2 \ |
| 13 | file://typo_pon.wvdial.1.patch \ |
| 14 | " |
| 15 | |
| 16 | SRC_URI[md5sum] = "37e9a2d664effe4efd44c0e1a20136de" |
| 17 | SRC_URI[sha256sum] = "99906d9560cbdbc97e1855e7b0a7169f1e11983be3ac539140423f09debced82" |
| 18 | |
| 19 | EXTRA_OEMAKE = "" |
| 20 | export WVLINK="${LD}" |
| 21 | |
| 22 | PARALLEL_MAKE = "" |
| 23 | |
| 24 | BUILD_CPPFLAGS += "-I${STAGING_INCDIR}/wvstreams" |
| 25 | |
| 26 | do_configure() { |
| 27 | sed -i 's/LDFLAGS+=-luniconf/LIBS+=-luniconf/' ${S}/Makefile |
| 28 | } |
| 29 | |
| 30 | do_install() { |
| 31 | oe_runmake prefix=${D}/usr PPPDIR=${D}/etc/ppp/peers install |
| 32 | } |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 33 | # http://errors.yoctoproject.org/Errors/Details/186959/ |
| 34 | EXCLUDE_FROM_WORLD_libc-musl = "1" |