Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | SUMMARY = "Protocol Buffers - structured data serialisation mechanism" |
| 2 | DESCRIPTION = "This is protobuf-c, a C implementation of the Google Protocol Buffers data \ |
| 3 | serialization format. It includes libprotobuf-c, a pure C library that \ |
| 4 | implements protobuf encoding and decoding, and protoc-c, a code generator that \ |
| 5 | converts Protocol Buffer .proto files to C descriptor code, based on the \ |
| 6 | original protoc. protobuf-c formerly included an RPC implementation; that code \ |
| 7 | has been split out into the protobuf-c-rpc project." |
| 8 | HOMEPAGE = "https://github.com/protobuf-c/protobuf-c" |
| 9 | SECTION = "console/tools" |
| 10 | LICENSE = "BSD-2-Clause" |
| 11 | LIC_FILES_CHKSUM = "file://LICENSE;md5=cb901168715f4782a2b06c3ddaefa558" |
| 12 | |
| 13 | DEPENDS = "protobuf-native protobuf" |
| 14 | |
| 15 | PV .= "+git${SRCPV}" |
| 16 | SRCREV = "269771b4b45d3aba04e59569f53600003db8d9ff" |
| 17 | |
Brad Bishop | c8f4712 | 2019-06-24 09:36:18 -0400 | [diff] [blame^] | 18 | SRC_URI = "git://github.com/protobuf-c/protobuf-c.git \ |
| 19 | file://protobuf3-compatibility.patch \ |
| 20 | " |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 21 | |
| 22 | S = "${WORKDIR}/git" |
| 23 | |
| 24 | #make sure c++11 is used |
| 25 | CXXFLAGS += "-std=c++11" |
| 26 | BUILD_CXXFLAGS += "-std=c++11" |
| 27 | |
| 28 | inherit autotools pkgconfig |
| 29 | |
| 30 | PACKAGE_BEFORE_PN = "${PN}-compiler" |
| 31 | |
| 32 | FILES_${PN}-compiler = "${bindir}" |
| 33 | |
| 34 | RDEPENDS_${PN}-compiler = "protobuf-compiler" |
| 35 | RDEPENDS_${PN}-dev += "${PN}-compiler" |
| 36 | |
| 37 | BBCLASSEXTEND = "native nativesdk" |