Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | require libgpiod.inc |
| 2 | |
| 3 | DEPENDS += "autoconf-archive-native" |
| 4 | |
Brad Bishop | c8f4712 | 2019-06-24 09:36:18 -0400 | [diff] [blame^] | 5 | SRC_URI[md5sum] = "bd52d764017215a30e2f014d2081dc3e" |
| 6 | SRC_URI[sha256sum] = "ebde83aaf14be3abd33e7a90faa487a2ee231e242897afe7fdefb765386b3c8b" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 7 | |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 8 | # enable tools and cxx bindings |
| 9 | PACKAGECONFIG ?= "cxx tools" |
| 10 | |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 11 | PACKAGECONFIG[cxx] = "--enable-bindings-cxx,--disable-bindings-cxx" |
Brad Bishop | c8f4712 | 2019-06-24 09:36:18 -0400 | [diff] [blame^] | 12 | PACKAGECONFIG[tests] = "--enable-tests,--disable-tests,kmod udev" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 13 | |
| 14 | PACKAGECONFIG[python3] = "--enable-bindings-python,--disable-bindings-python,python3" |
| 15 | inherit ${@bb.utils.contains('PACKAGECONFIG', 'python3', 'python3native', '', d)} |
| 16 | |
| 17 | PACKAGES =+ "${PN}-python" |
| 18 | FILES_${PN}-python = "${PYTHON_SITEPACKAGES_DIR}" |
| 19 | RRECOMMENDS_PYTHON = "${@bb.utils.contains('PACKAGECONFIG', 'python3', '${PN}-python', '',d)}" |
| 20 | RRECOMMENDS_${PN}-python += "${RRECOMMENDS_PYTHON}" |