Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 1 | SUMMARY = "The Python Programming Language" |
| 2 | HOMEPAGE = "http://www.python.org" |
| 3 | LICENSE = "PSFv2" |
| 4 | SECTION = "devel/python" |
| 5 | |
| 6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=e466242989bd33c1bd2b6a526a742498" |
| 7 | |
| 8 | SRC_URI = "http://www.python.org/ftp/python/${PV}/Python-${PV}.tar.xz \ |
| 9 | file://run-ptest \ |
| 10 | file://create_manifest3.py \ |
| 11 | file://get_module_deps3.py \ |
| 12 | file://python3-manifest.json \ |
| 13 | file://check_build_completeness.py \ |
| 14 | file://cgi_py.patch \ |
| 15 | file://0001-Do-not-add-usr-lib-termcap-to-linker-flags-to-avoid-.patch \ |
| 16 | ${@bb.utils.contains('PACKAGECONFIG', 'tk', '', 'file://avoid_warning_about_tkinter.patch', d)} \ |
| 17 | file://0001-Do-not-use-the-shell-version-of-python-config-that-w.patch \ |
| 18 | file://python-config.patch \ |
| 19 | file://0001-Makefile.pre-use-qemu-wrapper-when-gathering-profile.patch \ |
| 20 | file://0001-Do-not-hardcode-lib-as-location-for-site-packages-an.patch \ |
| 21 | file://0001-python3-use-cc_basename-to-replace-CC-for-checking-c.patch \ |
| 22 | file://0002-Don-t-do-runtime-test-to-get-float-byte-order.patch \ |
| 23 | file://0003-setup.py-pass-missing-libraries-to-Extension-for-mul.patch \ |
| 24 | file://0001-Lib-sysconfig.py-fix-another-place-where-lib-is-hard.patch \ |
| 25 | file://0001-Makefile-fix-Issue36464-parallel-build-race-problem.patch \ |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 26 | file://0001-bpo-36852-proper-detection-of-mips-architecture-for-.patch \ |
Brad Bishop | f3fd288 | 2019-06-21 08:06:37 -0400 | [diff] [blame] | 27 | file://crosspythonpath.patch \ |
Brad Bishop | c8f4712 | 2019-06-24 09:36:18 -0400 | [diff] [blame^] | 28 | file://reformat_sysconfig.py \ |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 29 | " |
| 30 | |
| 31 | SRC_URI_append_class-native = " \ |
| 32 | file://0001-distutils-sysconfig-append-STAGING_LIBDIR-python-sys.patch \ |
| 33 | file://12-distutils-prefix-is-inside-staging-area.patch \ |
| 34 | " |
| 35 | SRC_URI_append_class-nativesdk = " \ |
| 36 | file://0001-main.c-if-OEPYTHON3HOME-is-set-use-instead-of-PYTHON.patch \ |
| 37 | " |
| 38 | |
| 39 | SRC_URI[md5sum] = "93df27aec0cd18d6d42173e601ffbbfd" |
| 40 | SRC_URI[sha256sum] = "da60b54064d4cfcd9c26576f6df2690e62085123826cff2e667e72a91952d318" |
| 41 | |
| 42 | # exclude pre-releases for both python 2.x and 3.x |
| 43 | UPSTREAM_CHECK_REGEX = "[Pp]ython-(?P<pver>\d+(\.\d+)+).tar" |
| 44 | |
| 45 | CVE_PRODUCT = "python" |
| 46 | |
| 47 | PYTHON_MAJMIN = "3.7" |
| 48 | PYTHON_BINABI = "${PYTHON_MAJMIN}m" |
| 49 | |
| 50 | S = "${WORKDIR}/Python-${PV}" |
| 51 | |
| 52 | BBCLASSEXTEND = "native nativesdk" |
| 53 | |
| 54 | inherit autotools pkgconfig qemu ptest multilib_header update-alternatives |
| 55 | |
| 56 | MULTILIB_SUFFIX = "${@d.getVar('base_libdir',1).split('/')[-1]}" |
| 57 | |
| 58 | ALTERNATIVE_${PN}-dev = "python-config" |
| 59 | ALTERNATIVE_LINK_NAME[python-config] = "${bindir}/python${PYTHON_BINABI}-config" |
| 60 | ALTERNATIVE_TARGET[python-config] = "${bindir}/python${PYTHON_BINABI}-config-${MULTILIB_SUFFIX}" |
| 61 | |
| 62 | |
| 63 | DEPENDS = "bzip2-replacement-native libffi bzip2 gdbm openssl sqlite3 zlib virtual/libintl xz virtual/crypt util-linux libtirpc libnsl2" |
| 64 | DEPENDS_append_class-target = " python3-native" |
| 65 | DEPENDS_append_class-nativesdk = " python3-native" |
| 66 | |
| 67 | EXTRA_OECONF = " --without-ensurepip --enable-shared" |
| 68 | EXTRA_OECONF_append_class-native = " --bindir=${bindir}/${PN}" |
| 69 | |
Brad Bishop | f3fd288 | 2019-06-21 08:06:37 -0400 | [diff] [blame] | 70 | export CROSSPYTHONPATH="${STAGING_LIBDIR_NATIVE}/python${PYTHON_MAJMIN}/lib-dynload/" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 71 | |
| 72 | EXTRANATIVEPATH += "python3-native" |
| 73 | |
| 74 | CACHED_CONFIGUREVARS = " \ |
| 75 | ac_cv_file__dev_ptmx=yes \ |
| 76 | ac_cv_file__dev_ptc=no \ |
| 77 | ac_cv_working_tzset=yes \ |
| 78 | " |
Brad Bishop | f3fd288 | 2019-06-21 08:06:37 -0400 | [diff] [blame] | 79 | python() { |
| 80 | # PGO currently causes builds to not be reproducible, so disable it for |
| 81 | # now. See YOCTO #13407 |
| 82 | if bb.utils.contains('MACHINE_FEATURES', 'qemu-usermode', True, False, d) and d.getVar('BUILD_REPRODUCIBLE_BINARIES') != '1': |
| 83 | d.setVar('PACKAGECONFIG_PGO', 'pgo') |
| 84 | else: |
| 85 | d.setVar('PACKAGECONFIG_PGO', '') |
| 86 | } |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 87 | |
Brad Bishop | f3fd288 | 2019-06-21 08:06:37 -0400 | [diff] [blame] | 88 | PACKAGECONFIG_class-target ??= "readline ${PACKAGECONFIG_PGO}" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 89 | PACKAGECONFIG_class-native ??= "readline" |
| 90 | PACKAGECONFIG_class-nativesdk ??= "readline" |
| 91 | PACKAGECONFIG[readline] = ",,readline" |
| 92 | # Use profile guided optimisation by running PyBench inside qemu-user |
| 93 | PACKAGECONFIG[pgo] = "--enable-optimizations,,qemu-native" |
| 94 | PACKAGECONFIG[tk] = ",,tk" |
| 95 | |
| 96 | CPPFLAGS_append = " -I${STAGING_INCDIR}/ncursesw -I${STAGING_INCDIR}/uuid" |
| 97 | |
| 98 | EXTRA_OEMAKE = '\ |
| 99 | STAGING_LIBDIR=${STAGING_LIBDIR} \ |
| 100 | STAGING_INCDIR=${STAGING_INCDIR} \ |
| 101 | LIB=${baselib} \ |
| 102 | ' |
| 103 | |
| 104 | do_compile_prepend_class-target() { |
| 105 | if ${@bb.utils.contains('PACKAGECONFIG', 'pgo', 'true', 'false', d)}; then |
| 106 | qemu_binary="${@qemu_wrapper_cmdline(d, '${STAGING_DIR_TARGET}', ['${B}', '${STAGING_DIR_TARGET}/${base_libdir}'])}" |
| 107 | cat >pgo-wrapper <<EOF |
| 108 | #!/bin/sh |
| 109 | cd ${B} |
| 110 | $qemu_binary "\$@" |
| 111 | EOF |
| 112 | chmod +x pgo-wrapper |
| 113 | fi |
| 114 | } |
| 115 | |
| 116 | do_install_prepend() { |
| 117 | ${WORKDIR}/check_build_completeness.py ${T}/log.do_compile |
| 118 | } |
| 119 | |
| 120 | do_install_append_class-target() { |
| 121 | oe_multilib_header python${PYTHON_BINABI}/pyconfig.h |
| 122 | } |
| 123 | |
| 124 | do_install_append_class-native() { |
| 125 | # Make sure we use /usr/bin/env python |
| 126 | for PYTHSCRIPT in `grep -rIl ${bindir}/${PN}/python ${D}${bindir}/${PN}`; do |
| 127 | sed -i -e '1s|^#!.*|#!/usr/bin/env python3|' $PYTHSCRIPT |
| 128 | done |
| 129 | # Add a symlink to the native Python so that scripts can just invoke |
| 130 | # "nativepython" and get the right one without needing absolute paths |
| 131 | # (these often end up too long for the #! parser in the kernel as the |
| 132 | # buffer is 128 bytes long). |
| 133 | ln -s python3-native/python3 ${D}${bindir}/nativepython3 |
| 134 | } |
| 135 | |
| 136 | do_install_append() { |
| 137 | mkdir -p ${D}${libdir}/python-sysconfigdata |
| 138 | sysconfigfile=`find ${D} -name _sysconfig*.py` |
| 139 | cp $sysconfigfile ${D}${libdir}/python-sysconfigdata/_sysconfigdata.py |
| 140 | |
| 141 | sed -i \ |
| 142 | -e "s,^ 'LIBDIR'.*, 'LIBDIR': '${STAGING_LIBDIR}'\,,g" \ |
| 143 | -e "s,^ 'INCLUDEDIR'.*, 'INCLUDEDIR': '${STAGING_INCDIR}'\,,g" \ |
| 144 | -e "s,^ 'CONFINCLUDEDIR'.*, 'CONFINCLUDEDIR': '${STAGING_INCDIR}'\,,g" \ |
| 145 | -e "/^ 'INCLDIRSTOMAKE'/{N; s,/usr/include,${STAGING_INCDIR},g}" \ |
| 146 | -e "/^ 'INCLUDEPY'/s,/usr/include,${STAGING_INCDIR},g" \ |
| 147 | ${D}${libdir}/python-sysconfigdata/_sysconfigdata.py |
| 148 | } |
| 149 | |
| 150 | do_install_append_class-nativesdk () { |
| 151 | create_wrapper ${D}${bindir}/python${PYTHON_MAJMIN} OEPYTHON3HOME='${prefix}' TERMINFO_DIRS='${sysconfdir}/terminfo:/etc/terminfo:/usr/share/terminfo:/usr/share/misc/terminfo:/lib/terminfo' PYTHONNOUSERSITE='1' |
| 152 | } |
| 153 | |
| 154 | SSTATE_SCAN_FILES += "Makefile _sysconfigdata.py" |
| 155 | PACKAGE_PREPROCESS_FUNCS += "py_package_preprocess" |
| 156 | |
| 157 | py_package_preprocess () { |
| 158 | # Remove references to buildmachine paths in target Makefile and _sysconfigdata |
| 159 | sed -i -e 's:--sysroot=${STAGING_DIR_TARGET}::g' -e s:'--with-libtool-sysroot=${STAGING_DIR_TARGET}'::g \ |
| 160 | -e 's|${DEBUG_PREFIX_MAP}||g' \ |
| 161 | -e 's:${HOSTTOOLS_DIR}/::g' \ |
| 162 | -e 's:${RECIPE_SYSROOT_NATIVE}::g' \ |
| 163 | -e 's:${RECIPE_SYSROOT}::g' \ |
| 164 | -e 's:${BASE_WORKDIR}/${MULTIMACH_TARGET_SYS}::g' \ |
| 165 | ${PKGD}/${prefix}/lib/python${PYTHON_MAJMIN}/config-${PYTHON_MAJMIN}${PYTHON_ABI}*/Makefile \ |
| 166 | ${PKGD}/${libdir}/python${PYTHON_MAJMIN}/_sysconfigdata*.py \ |
| 167 | ${PKGD}/${bindir}/python${PYTHON_BINABI}-config |
| 168 | |
Brad Bishop | c8f4712 | 2019-06-24 09:36:18 -0400 | [diff] [blame^] | 169 | # Reformat _sysconfigdata after modifying it so that it remains |
| 170 | # reproducible |
| 171 | for c in ${PKGD}/${libdir}/python${PYTHON_MAJMIN}/_sysconfigdata*.py; do |
| 172 | python3 ${WORKDIR}/reformat_sysconfig.py $c |
| 173 | done |
| 174 | |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 175 | # Recompile _sysconfigdata after modifying it |
| 176 | cd ${PKGD} |
| 177 | sysconfigfile=`find . -name _sysconfigdata_*.py` |
| 178 | ${STAGING_BINDIR_NATIVE}/python3-native/python3 \ |
| 179 | -c "from py_compile import compile; compile('$sysconfigfile')" |
| 180 | ${STAGING_BINDIR_NATIVE}/python3-native/python3 \ |
| 181 | -c "from py_compile import compile; compile('$sysconfigfile', optimize=1)" |
| 182 | ${STAGING_BINDIR_NATIVE}/python3-native/python3 \ |
| 183 | -c "from py_compile import compile; compile('$sysconfigfile', optimize=2)" |
| 184 | cd - |
| 185 | |
| 186 | mv ${PKGD}/${bindir}/python${PYTHON_BINABI}-config ${PKGD}/${bindir}/python${PYTHON_BINABI}-config-${MULTILIB_SUFFIX} |
| 187 | |
| 188 | #Remove the unneeded copy of target sysconfig data |
| 189 | rm -rf ${PKGD}/${libdir}/python-sysconfigdata |
| 190 | } |
| 191 | |
| 192 | # We want bytecode precompiled .py files (.pyc's) by default |
| 193 | # but the user may set it on their own conf |
| 194 | INCLUDE_PYCS ?= "1" |
| 195 | |
| 196 | python(){ |
| 197 | import collections, json |
| 198 | |
| 199 | filename = os.path.join(d.getVar('THISDIR'), 'python3', 'python3-manifest.json') |
| 200 | # This python changes the datastore based on the contents of a file, so mark |
| 201 | # that dependency. |
| 202 | bb.parse.mark_dependency(d, filename) |
| 203 | |
| 204 | with open(filename) as manifest_file: |
| 205 | manifest_str = manifest_file.read() |
| 206 | json_start = manifest_str.find('# EOC') + 6 |
| 207 | manifest_file.seek(json_start) |
| 208 | manifest_str = manifest_file.read() |
| 209 | python_manifest = json.loads(manifest_str, object_pairs_hook=collections.OrderedDict) |
| 210 | |
| 211 | # First set RPROVIDES for -native case |
| 212 | # Hardcoded since it cant be python3-native-foo, should be python3-foo-native |
| 213 | pn = 'python3' |
| 214 | rprovides = d.getVar('RPROVIDES').split() |
| 215 | |
| 216 | for key in python_manifest: |
| 217 | pypackage = pn + '-' + key + '-native' |
| 218 | if pypackage not in rprovides: |
| 219 | rprovides.append(pypackage) |
| 220 | |
| 221 | d.setVar('RPROVIDES_class-native', ' '.join(rprovides)) |
| 222 | |
| 223 | # Then work on the target |
| 224 | include_pycs = d.getVar('INCLUDE_PYCS') |
| 225 | |
| 226 | packages = d.getVar('PACKAGES').split() |
| 227 | pn = d.getVar('PN') |
| 228 | |
| 229 | newpackages=[] |
| 230 | for key in python_manifest: |
| 231 | pypackage= pn + '-' + key |
| 232 | |
| 233 | if pypackage not in packages: |
| 234 | # We need to prepend, otherwise python-misc gets everything |
| 235 | # so we use a new variable |
| 236 | newpackages.append(pypackage) |
| 237 | |
| 238 | # "Build" python's manifest FILES, RDEPENDS and SUMMARY |
| 239 | d.setVar('FILES_' + pypackage, '') |
| 240 | for value in python_manifest[key]['files']: |
| 241 | d.appendVar('FILES_' + pypackage, ' ' + value) |
| 242 | |
| 243 | # Add cached files |
| 244 | if include_pycs == '1': |
| 245 | for value in python_manifest[key]['cached']: |
| 246 | d.appendVar('FILES_' + pypackage, ' ' + value) |
| 247 | |
| 248 | for value in python_manifest[key]['rdepends']: |
| 249 | # Make it work with or without $PN |
| 250 | if '${PN}' in value: |
| 251 | value=value.split('-')[1] |
| 252 | d.appendVar('RDEPENDS_' + pypackage, ' ' + pn + '-' + value) |
| 253 | d.setVar('SUMMARY_' + pypackage, python_manifest[key]['summary']) |
| 254 | |
| 255 | # Prepending so to avoid python-misc getting everything |
| 256 | packages = newpackages + packages |
| 257 | d.setVar('PACKAGES', ' '.join(packages)) |
| 258 | d.setVar('ALLOW_EMPTY_${PN}-modules', '1') |
| 259 | } |
| 260 | |
| 261 | # Files needed to create a new manifest |
| 262 | |
| 263 | do_create_manifest() { |
| 264 | # This task should be run with every new release of Python. |
| 265 | # We must ensure that PACKAGECONFIG enables everything when creating |
| 266 | # a new manifest, this is to base our new manifest on a complete |
| 267 | # native python build, containing all dependencies, otherwise the task |
| 268 | # wont be able to find the required files. |
| 269 | # e.g. BerkeleyDB is an optional build dependency so it may or may not |
| 270 | # be present, we must ensure it is. |
| 271 | |
| 272 | cd ${WORKDIR} |
| 273 | # This needs to be executed by python-native and NOT by HOST's python |
| 274 | nativepython3 create_manifest3.py ${PYTHON_MAJMIN} |
| 275 | cp python3-manifest.json.new ${THISDIR}/python3/python3-manifest.json |
| 276 | } |
| 277 | |
| 278 | # bitbake python -c create_manifest |
| 279 | addtask do_create_manifest |
| 280 | |
| 281 | # Make sure we have native python ready when we create a new manifest |
| 282 | do_create_manifest[depends] += "${PN}:do_prepare_recipe_sysroot" |
| 283 | do_create_manifest[depends] += "${PN}:do_patch" |
| 284 | |
| 285 | # manual dependency additions |
| 286 | RPROVIDES_${PN}-modules = "${PN}" |
| 287 | RRECOMMENDS_${PN}-core_append_class-nativesdk = " nativesdk-python3-modules" |
| 288 | RRECOMMENDS_${PN}-crypt_append_class-target = " openssl ca-certificates" |
| 289 | RRECOMMENDS_${PN}-crypt_append_class-nativesdk = " openssl ca-certificates" |
| 290 | |
| 291 | FILES_${PN}-pydoc += "${bindir}/pydoc${PYTHON_MAJMIN} ${bindir}/pydoc3" |
| 292 | FILES_${PN}-idle += "${bindir}/idle3 ${bindir}/idle${PYTHON_MAJMIN}" |
| 293 | |
| 294 | # provide python-pyvenv from python3-venv |
| 295 | RPROVIDES_${PN}-venv += "python3-pyvenv" |
| 296 | |
| 297 | # package libpython3 |
| 298 | PACKAGES =+ "libpython3 libpython3-staticdev" |
| 299 | FILES_libpython3 = "${libdir}/libpython*.so.*" |
| 300 | FILES_libpython3-staticdev += "${prefix}/lib/python${PYTHON_MAJMIN}/config-${PYTHON_BINABI}-*/libpython${PYTHON_BINABI}.a" |
| 301 | INSANE_SKIP_${PN}-dev += "dev-elf" |
| 302 | |
| 303 | # catch all the rest (unsorted) |
| 304 | PACKAGES += "${PN}-misc" |
| 305 | RDEPENDS_${PN}-misc += "python3-core python3-email python3-codecs" |
| 306 | RDEPENDS_${PN}-modules_append_class-target = " python3-misc" |
| 307 | RDEPENDS_${PN}-modules_append_class-nativesdk = " python3-misc" |
| 308 | FILES_${PN}-misc = "${libdir}/python${PYTHON_MAJMIN} ${libdir}/python${PYTHON_MAJMIN}/lib-dynload" |
| 309 | |
| 310 | # catch manpage |
| 311 | PACKAGES += "${PN}-man" |
| 312 | FILES_${PN}-man = "${datadir}/man" |
| 313 | |
| 314 | RDEPENDS_${PN}-ptest = "${PN}-modules ${PN}-tests unzip bzip2 libgcc tzdata-europe coreutils sed" |
| 315 | RDEPENDS_${PN}-ptest_append_libc-glibc = " locale-base-tr-tr.iso-8859-9" |
| 316 | RDEPENDS_${PN}-tkinter += "${@bb.utils.contains('PACKAGECONFIG', 'tk', 'tk', '', d)}" |
| 317 | RDEPENDS_${PN}-dev = "" |
| 318 | |