Andrew Geissler | c9f7865 | 2020-09-18 14:11:35 -0500 | [diff] [blame^] | 1 | SUMMARY = "ISC Kea DHCP Server" |
| 2 | DESCRIPTION = "Kea is the next generation of DHCP software developed by ISC. It supports both DHCPv4 and DHCPv6 protocols along with their extensions, e.g. prefix delegation and dynamic updates to DNS." |
| 3 | HOMEPAGE = "http://kea.isc.org" |
| 4 | SECTION = "connectivity" |
| 5 | LICENSE = "MPL-2.0 & Apache-2.0" |
| 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=68d95543d2096459290a4e6b9ceccffa" |
| 7 | |
| 8 | DEPENDS = "boost log4cplus openssl" |
| 9 | |
| 10 | SRC_URI = "\ |
| 11 | http://ftp.isc.org/isc/kea/${PV}/${BP}.tar.gz \ |
| 12 | file://kea-dhcp4.service \ |
| 13 | file://kea-dhcp6.service \ |
| 14 | file://kea-dhcp-ddns.service \ |
| 15 | " |
| 16 | SRC_URI[sha256sum] = "4e121f0e58b175a827581c69cb1d60778647049fa47f142940dddc9ce58f3c82" |
| 17 | |
| 18 | inherit autotools systemd |
| 19 | |
| 20 | SYSTEMD_SERVICE_${PN} = "kea-dhcp4.service kea-dhcp6.service kea-dhcp-ddns.service" |
| 21 | SYSTEMD_AUTO_ENABLE = "disable" |
| 22 | |
| 23 | DEBUG_OPTIMIZATION_remove_mips = " -Og" |
| 24 | DEBUG_OPTIMIZATION_append_mips = " -O" |
| 25 | BUILD_OPTIMIZATION_remove_mips = " -Og" |
| 26 | BUILD_OPTIMIZATION_append_mips = " -O" |
| 27 | |
| 28 | DEBUG_OPTIMIZATION_remove_mipsel = " -Og" |
| 29 | DEBUG_OPTIMIZATION_append_mipsel = " -O" |
| 30 | BUILD_OPTIMIZATION_remove_mipsel = " -Og" |
| 31 | BUILD_OPTIMIZATION_append_mipsel = " -O" |
| 32 | |
| 33 | EXTRA_OECONF = "--with-boost-libs=-lboost_system \ |
| 34 | --with-log4cplus=${STAGING_DIR_TARGET}${prefix} \ |
| 35 | --with-openssl=${STAGING_DIR_TARGET}${prefix}" |
| 36 | |
| 37 | do_configure_prepend() { |
| 38 | # replace abs_top_builddir to avoid introducing the build path |
| 39 | # don't expand the abs_top_builddir on the target as the abs_top_builddir is meanlingless on the target |
| 40 | find ${S} -type f -name *.sh.in | xargs sed -i "s:@abs_top_builddir@:@abs_top_builddir_placeholder@:g" |
| 41 | sed -i "s:@abs_top_srcdir@:@abs_top_srcdir_placeholder@:g" ${S}/src/bin/admin/kea-admin.in |
| 42 | } |
| 43 | |
| 44 | do_install_append() { |
| 45 | install -d ${D}${systemd_system_unitdir} |
| 46 | install -m 0644 ${WORKDIR}/kea-dhcp*service ${D}${systemd_system_unitdir} |
| 47 | sed -i -e 's,@SBINDIR@,${sbindir},g' -e 's,@BASE_BINDIR@,${base_bindir},g' \ |
| 48 | -e 's,@LOCALSTATEDIR@,${localstatedir},g' -e 's,@SYSCONFDIR@,${sysconfdir},g' \ |
| 49 | ${D}${systemd_system_unitdir}/kea-dhcp*service |
| 50 | } |
| 51 | |
| 52 | do_install_append() { |
| 53 | rm -rf "${D}${localstatedir}" |
| 54 | } |
| 55 | |
| 56 | FILES_${PN}-staticdev += "${libdir}/kea/hooks/*.a ${libdir}/hooks/*.a" |
| 57 | FILES_${PN} += "${libdir}/hooks/*.so" |
| 58 | |
| 59 | PARALLEL_MAKEINST = "" |