Andrew Geissler | eff2747 | 2021-10-29 15:35:00 -0500 | [diff] [blame] | 1 | SUMMARY = "GNOME Online Accounts - Single sign-on framework for GNOME" |
| 2 | LICENSE = "LGPLv2+" |
| 3 | LIC_FILES_CHKSUM = "file://COPYING;md5=34c88b124db5fb2762c1676be7dadd36" |
| 4 | |
| 5 | GNOMEBASEBUILDCLASS = "autotools" |
| 6 | |
| 7 | inherit gnomebase gsettings gobject-introspection gsettings gtk-doc vala gettext features_check |
| 8 | |
| 9 | # for webkitgtk |
| 10 | REQUIRED_DISTRO_FEATURES = "x11" |
| 11 | |
| 12 | DEPENDS = "glib-2.0" |
| 13 | |
| 14 | SRC_URI += "\ |
| 15 | file://0001-Use-GUri-instead-of-SoupURI.patch \ |
| 16 | file://0002-Port-to-libsoup3.patch \ |
| 17 | " |
| 18 | SRC_URI[archive.sha256sum] = "3bcb3663a12efd4482d9fdda3e171676267fc739eb6440a2b7109a0e87afb7e8" |
| 19 | |
| 20 | # backend is required for gnome-control-center |
| 21 | PACKAGECONFIG = "backend other" |
| 22 | |
| 23 | PACKAGECONFIG[backend] = "--enable-backend,--disable-backend,gtk+3 webkitgtk libsoup json-glib libsecret rest libxml2" |
| 24 | PACKAGECONFIG[krb5] = "--enable-kerberos, --disable-kerberos , krb5 gcr" |
| 25 | |
| 26 | # no extra dependencies! |
| 27 | PACKAGECONFIG[other] = " \ |
| 28 | --enable-facebook --enable-foursquare --enable-exchange --enable-flickr --enable-google --enable-imap-smtp --enable-owncloud --enable-windows-live,\ |
| 29 | --disable-facebook --disable-foursquare --disable-exchange --disable-flickr --disable-google --disable-imap-smtp --disable-owncloud --disable-windows-live, \ |
| 30 | " |
| 31 | |
| 32 | FILES:${PN} += " \ |
| 33 | ${datadir}/dbus-1 \ |
| 34 | ${libdir}/goa-1.0/web-extensions/*.so \ |
| 35 | " |
| 36 | |
| 37 | # looked into pkg-config file: it is not a bug - they mean it |
| 38 | FILES:${PN}-dev += "${libdir}/goa-1.0/include" |