Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 1 | SUMMARY = "udisks provides dbus interfaces for disks and storage devices" |
| 2 | LICENSE = "GPLv2+ & LGPLv2+" |
| 3 | LIC_FILES_CHKSUM = "file://COPYING;md5=dd79f6dbbffdbc8e86b086a8f0c0ef43" |
| 4 | |
| 5 | DEPENDS = " \ |
Andrew Geissler | bffdb3e | 2020-08-21 16:13:29 -0500 | [diff] [blame] | 6 | glib-2.0-native \ |
| 7 | libxslt-native \ |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 8 | acl \ |
| 9 | libatasmart \ |
| 10 | polkit \ |
| 11 | libgudev \ |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 12 | glib-2.0 \ |
Andrew Geissler | bffdb3e | 2020-08-21 16:13:29 -0500 | [diff] [blame] | 13 | dbus-glib \ |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 14 | libblockdev \ |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 15 | " |
| 16 | DEPENDS += "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}" |
| 17 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 18 | RDEPENDS:${PN} = "acl" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 19 | |
Andrew Geissler | d159c7f | 2021-09-02 21:05:58 -0500 | [diff] [blame] | 20 | SRC_URI = "git://github.com/storaged-project/udisks.git;branch=2.9.x-branch" |
| 21 | SRCREV = "c430dd9a27e158693cc783e9ee91bf6e5b2a8819" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 22 | S = "${WORKDIR}/git" |
| 23 | |
| 24 | CVE_PRODUCT = "udisks" |
| 25 | |
Andrew Geissler | bffdb3e | 2020-08-21 16:13:29 -0500 | [diff] [blame] | 26 | inherit autotools-brokensep systemd gtk-doc gobject-introspection gettext features_check |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 27 | |
| 28 | REQUIRED_DISTRO_FEATURES = "polkit" |
| 29 | |
| 30 | EXTRA_OECONF = "--disable-man --disable-gtk-doc" |
| 31 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 32 | do_configure:prepend() { |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 33 | # | configure.ac:656: error: required file 'build-aux/config.rpath' not found |
| 34 | mkdir -p ${S}/build-aux |
| 35 | touch ${S}/build-aux/config.rpath |
| 36 | } |
| 37 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 38 | FILES:${PN} += " \ |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 39 | ${datadir}/dbus-1/ \ |
| 40 | ${datadir}/polkit-1 \ |
| 41 | ${datadir}/bash-completion \ |
| 42 | ${libdir}/polkit-1/extensions/*.so \ |
| 43 | ${nonarch_base_libdir}/udev/* \ |
| 44 | ${exec_prefix}${nonarch_base_libdir}/udisks2/* \ |
| 45 | ${systemd_system_unitdir} \ |
| 46 | " |
| 47 | |
| 48 | PACKAGES =+ "${PN}-libs" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 49 | FILES:${PN}-libs = "${libdir}/lib*${SOLIBS}" |
| 50 | FILES:${PN} += "${nonarch_libdir}/tmpfiles.d" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 51 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 52 | SYSTEMD_SERVICE:${PN} = "${BPN}.service" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 53 | SYSTEMD_AUTO_ENABLE = "disable" |