Andrew Geissler | eff2747 | 2021-10-29 15:35:00 -0500 | [diff] [blame] | 1 | DESCRIPTION = "Google gRPC tools" |
| 2 | HOMEPAGE = "http://www.grpc.io/" |
| 3 | SECTION = "devel/python" |
| 4 | |
| 5 | LICENSE = "Apache-2.0" |
| 6 | LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=7145f7cdd263359b62d342a02f005515" |
| 7 | |
| 8 | inherit pypi setuptools3 |
| 9 | |
| 10 | DEPENDS += "${PYTHON_PN}-grpcio" |
| 11 | |
| 12 | SRC_URI += "file://0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch" |
| 13 | |
| 14 | SRC_URI[sha256sum] = "3891b1df82369acbc8451d4952cd20755f49a82398dce62437511ad17b47290e" |
| 15 | |
| 16 | RDEPENDS:${PN} = "${PYTHON_PN}-grpcio" |
| 17 | |
| 18 | BBCLASSEXTEND = "native nativesdk" |
| 19 | |
| 20 | # Needs abseil-cpp which does not build for ppc64le/musl |
| 21 | COMPATIBLE_HOST:libc-musl:powerpc64le = "null" |
| 22 | |