Andrew Geissler | eff2747 | 2021-10-29 15:35:00 -0500 | [diff] [blame] | 1 | SUMMARY = "Python project template generator with batteries included" |
| 2 | DESCRIPTION = "PyScaffold package helps to setup a new Python project. \ |
| 3 | After installation, it provides a new command [putup], which could be \ |
| 4 | used to create template Projects." |
| 5 | |
| 6 | HOMEPAGE = "https://github.com/pyscaffold/pyscaffold" |
| 7 | SECTION = "devel/python" |
| 8 | LICENSE = "MIT" |
| 9 | LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=8227180126797a0148f94f483f3e1489" |
| 10 | |
| 11 | inherit pypi setuptools3 |
| 12 | |
| 13 | PYPI_PACKAGE = "PyScaffold" |
| 14 | |
| 15 | SRC_URI[sha256sum] = "8972252fda90d1020a93f1e99db370c002d18f52ff2fca9c3cc2a0aee74d07ad" |
| 16 | |
| 17 | BBCLASSEXTEND = "native nativesdk" |
| 18 | |
| 19 | RDEPENDS:${PN} += " \ |
| 20 | python3-email \ |
| 21 | python3-compression \ |
| 22 | " |