Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "Supervisor: A Process Control System" |
| 2 | DESCRIPTION = "\ |
| 3 | Supervisor is a client/server system that allows its users \ |
| 4 | to monitorand control a number of processes on UNIX-like \ |
| 5 | operating systems." |
| 6 | HOMEPAGE = "https://github.com/Supervisor/supervisor" |
| 7 | LICENSE = "BSD-4-Clause" |
| 8 | LIC_FILES_CHKSUM = "file://LICENSES.txt;md5=5b4e3a2172bba4c47cded5885e7e507e" |
| 9 | |
Andrew Geissler | f103a7f | 2021-05-07 16:09:40 -0500 | [diff] [blame] | 10 | SRC_URI[sha256sum] = "5b2b8882ec8a3c3733cce6965cc098b6d80b417f21229ab90b18fe551d619f90" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 11 | |
| 12 | PYPI_PACKAGE = "supervisor" |
| 13 | inherit pypi systemd setuptools3 |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 14 | RDEPENDS:${PN} = "\ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 15 | ${PYTHON_PN}-meld3 \ |
| 16 | " |
| 17 | |
| 18 | SRC_URI += "file://supervisord.conf \ |
| 19 | file://supervisor.service \ |
| 20 | " |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 21 | SYSTEMD_SERVICE:${PN} = "supervisor.service" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 22 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 23 | do_install:append() { |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 24 | install -d ${D}${sysconfdir}/supervisor |
| 25 | install -d ${D}${systemd_system_unitdir} |
| 26 | |
| 27 | install -m 0644 ${WORKDIR}/supervisord.conf ${D}${sysconfdir}/supervisor |
| 28 | install -m 0644 ${WORKDIR}/supervisor.service ${D}${systemd_system_unitdir} |
| 29 | } |