Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "ACPICA tools for the development and debug of ACPI tables" |
| 2 | DESCRIPTION = "The ACPI Component Architecture (ACPICA) project provides an \ |
| 3 | OS-independent reference implementation of the Advanced Configuration and \ |
| 4 | Power Interface Specification (ACPI). ACPICA code contains those portions of \ |
| 5 | ACPI meant to be directly integrated into the host OS as a kernel-resident \ |
| 6 | subsystem, and a small set of tools to assist in developing and debugging \ |
| 7 | ACPI tables." |
| 8 | |
| 9 | HOMEPAGE = "http://www.acpica.org/" |
| 10 | SECTION = "console/tools" |
| 11 | |
| 12 | LICENSE = "Intel | BSD | GPLv2" |
Andrew Geissler | d1e8949 | 2021-02-12 15:35:20 -0600 | [diff] [blame] | 13 | LIC_FILES_CHKSUM = "file://source/compiler/aslcompile.c;beginline=7;endline=150;md5=c33ce358fdcd142684e41e336b7992e8" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 14 | |
| 15 | COMPATIBLE_HOST = "(i.86|x86_64|arm|aarch64).*-linux" |
| 16 | |
| 17 | DEPENDS = "m4-native flex-native bison-native" |
| 18 | |
| 19 | SRC_URI = "https://acpica.org/sites/acpica/files/acpica-unix-${PV}.tar.gz" |
Andrew Geissler | d1e8949 | 2021-02-12 15:35:20 -0600 | [diff] [blame] | 20 | SRC_URI[sha256sum] = "a9be7b749025e60f93fde2fe531bfe0d84a33641d3e0c9b0f6049f996dbb1ff8" |
Andrew Geissler | 1e34c2d | 2020-05-29 16:02:59 -0500 | [diff] [blame] | 21 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 22 | UPSTREAM_CHECK_URI = "https://acpica.org/downloads" |
| 23 | |
| 24 | S = "${WORKDIR}/acpica-unix-${PV}" |
| 25 | |
| 26 | inherit update-alternatives |
| 27 | |
| 28 | ALTERNATIVE_PRIORITY = "100" |
| 29 | ALTERNATIVE_${PN} = "acpixtract acpidump" |
| 30 | |
| 31 | EXTRA_OEMAKE = "CC='${CC}' \ |
| 32 | OPT_CFLAGS=-Wall \ |
| 33 | DESTDIR=${D} \ |
| 34 | PREFIX=${prefix} \ |
| 35 | INSTALLDIR=${bindir} \ |
| 36 | INSTALLFLAGS= \ |
Andrew Geissler | 9b4d8b0 | 2021-02-19 12:26:16 -0600 | [diff] [blame] | 37 | YACC=bison \ |
| 38 | YFLAGS='-y --file-prefix-map=${WORKDIR}=/usr/src/debug/${PN}/${EXTENDPE}${PV}-${PR}' \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 39 | " |
| 40 | |
| 41 | do_install() { |
| 42 | oe_runmake install |
| 43 | } |
| 44 | |
| 45 | # iasl*.bb is a subset of this recipe, so RREPLACE it |
| 46 | PROVIDES = "iasl" |
| 47 | RPROVIDES_${PN} += "iasl" |
| 48 | RREPLACES_${PN} += "iasl" |
| 49 | RCONFLICTS_${PN} += "iasl" |
| 50 | |
| 51 | BBCLASSEXTEND = "native" |