Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "A Python library for building configuration shells" |
| 2 | DESCRIPTION = "configshell-fb is a Python library that provides a framework for \ |
| 3 | building simple but nice CLI-based applications. This runs with Python 2 and \ |
| 4 | 2to3 is run by setup.py to run on Python 3." |
| 5 | |
| 6 | LICENSE = "Apache-2.0" |
| 7 | LIC_FILES_CHKSUM = "file://COPYING;md5=1dece7821bf3fd70fe1309eaa37d52a2" |
| 8 | |
| 9 | SRC_URI = "git://github.com/open-iscsi/configshell-fb.git;protocol=https;branch=master" |
| 10 | SRCREV = "da8f0cef114e7343a7ae96ff1db7c8c574f819be" |
| 11 | |
| 12 | S = "${WORKDIR}/git" |
| 13 | |
| 14 | inherit setuptools3 |
| 15 | |
| 16 | RDEPENDS_${PN} += "python3-modules python3-fcntl python3-six" |