Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 1 | SUMMARY = "The Geolocation Service" |
| 2 | DESCRIPTION = "Geoclue is a D-Bus service that provides location information. \ |
| 3 | The primary goal of the Geoclue project is to make creating location-aware applications \ |
| 4 | as simple as possible, while the secondary goal is to ensure that no application \ |
| 5 | can access location information without explicit permission from user." |
| 6 | LICENSE = "GPLv2.0+" |
| 7 | SECTION = "console/network" |
| 8 | |
| 9 | LIC_FILES_CHKSUM = "file://COPYING;md5=bdfdd4986a0853eb84eeba85f9d0c4d6" |
| 10 | |
| 11 | DEPENDS = "glib-2.0 dbus json-glib libsoup-2.4 intltool-native" |
| 12 | |
| 13 | inherit meson pkgconfig gtk-doc gobject-introspection vala |
| 14 | |
Andrew Geissler | 72956ed | 2021-01-08 16:11:14 -0600 | [diff] [blame] | 15 | SRCREV = "3bb60dd600a8b247fd6049e7e5b1c73c2c5fc0e8" |
Andrew Geissler | 4b7c115 | 2020-11-30 19:55:29 -0600 | [diff] [blame] | 16 | SRC_URI = "git://gitlab.freedesktop.org/geoclue/geoclue.git;protocol=https;nobranch=1" |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 17 | |
Andrew Geissler | 4b7c115 | 2020-11-30 19:55:29 -0600 | [diff] [blame] | 18 | S = "${WORKDIR}/git" |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 19 | |
| 20 | # Without this line, package is declared a library and named libgeoclue* |
| 21 | AUTO_LIBNAME_PKGS = "" |
| 22 | |
| 23 | PACKAGECONFIG ??= "3g modem-gps cdma nmea lib" |
| 24 | PACKAGECONFIG[3g] = "-D3g-source=true,-D3g-source=false,modemmanager" |
| 25 | PACKAGECONFIG[modem-gps] = "-Dmodem-gps-source=true,-Dmodem-gps-source=false,modemmanager" |
| 26 | PACKAGECONFIG[cdma] = "-Dcdma-source=true,-Dcdma-source=false,modemmanager" |
Andrew Geissler | 89770b0 | 2020-06-13 10:40:47 -0500 | [diff] [blame] | 27 | PACKAGECONFIG[nmea] = "-Dnmea-source=true,-Dnmea-source=false,avahi,avahi-daemon" |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 28 | PACKAGECONFIG[lib] = "-Dlibgeoclue=true,-Dlibgeoclue=false,gobject-introspection" |
| 29 | |
| 30 | GTKDOC_MESON_OPTION = "gtk-doc" |
| 31 | |
| 32 | EXTRA_OEMESON += " \ |
| 33 | -Ddbus-sys-dir=${sysconfdir}/dbus-1/system.d \ |
| 34 | -Ddemo-agent=false \ |
| 35 | " |
| 36 | |
| 37 | FILES_${PN} += " \ |
| 38 | ${datadir}/dbus-1/system-services \ |
| 39 | ${libdir} \ |
| 40 | ${systemd_unitdir} \ |
| 41 | ${prefix}/libexec \ |
| 42 | " |
| 43 | |
| 44 | FILES_${PN}-dev += " \ |
| 45 | ${datadir}/dbus-1/interfaces \ |
| 46 | ${datadir}/gir-1.0 \ |
| 47 | " |