Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "WebP is an image format designed for the Web" |
| 2 | DESCRIPTION = "WebP is a method of lossy and lossless compression that can be \ |
| 3 | used on a large variety of photographic, translucent and \ |
| 4 | graphical images found on the web. The degree of lossy \ |
| 5 | compression is adjustable so a user can choose the trade-off \ |
| 6 | between file size and image quality. WebP typically achieves \ |
| 7 | an average of 30% more compression than JPEG and JPEG 2000, \ |
| 8 | without loss of image quality." |
| 9 | HOMEPAGE = "https://developers.google.com/speed/webp/" |
| 10 | SECTION = "libs" |
| 11 | |
| 12 | LICENSE = "BSD-3-Clause" |
| 13 | LIC_FILES_CHKSUM = "file://COPYING;md5=6e8dee932c26f2dab503abf70c96d8bb \ |
| 14 | file://PATENTS;md5=c6926d0cb07d296f886ab6e0cc5a85b7" |
| 15 | |
| 16 | SRC_URI = "http://downloads.webmproject.org/releases/webp/${BP}.tar.gz" |
| 17 | SRC_URI[md5sum] = "7e047f2cbaf584dff7a8a7e0f8572f18" |
| 18 | SRC_URI[sha256sum] = "98a052268cc4d5ece27f76572a7f50293f439c17a98e67c4ea0c7ed6f50ef043" |
| 19 | |
| 20 | UPSTREAM_CHECK_URI = "http://downloads.webmproject.org/releases/webp/index.html" |
| 21 | |
| 22 | EXTRA_OECONF = " \ |
| 23 | --disable-wic \ |
| 24 | --enable-libwebpmux \ |
| 25 | --enable-libwebpdemux \ |
| 26 | --enable-threading \ |
| 27 | " |
| 28 | |
| 29 | # Do not trust configure to determine if neon is available. |
| 30 | # |
| 31 | EXTRA_OECONF_ARM = " \ |
| 32 | ${@bb.utils.contains("TUNE_FEATURES","neon","--enable-neon","--disable-neon",d)} \ |
| 33 | " |
| 34 | EXTRA_OECONF_append_arm = " ${EXTRA_OECONF_ARM}" |
| 35 | EXTRA_OECONF_append_armeb = " ${EXTRA_OECONF_ARM}" |
| 36 | |
| 37 | inherit autotools lib_package |
| 38 | |
| 39 | PACKAGECONFIG ??= "" |
| 40 | |
| 41 | # libwebpdecoder is a subset of libwebp, don't build it unless requested |
| 42 | PACKAGECONFIG[decoder] = "--enable-libwebpdecoder,--disable-libwebpdecoder" |
| 43 | |
| 44 | # Apply for examples programs: cwebp and dwebp |
| 45 | PACKAGECONFIG[gif] = "--enable-gif,--disable-gif,giflib" |
| 46 | PACKAGECONFIG[jpeg] = "--enable-jpeg,--disable-jpeg,jpeg" |
| 47 | PACKAGECONFIG[png] = "--enable-png,--disable-png,,libpng" |
| 48 | PACKAGECONFIG[tiff] = "--enable-tiff,--disable-tiff,tiff" |
| 49 | |
| 50 | # Apply only for example program vwebp |
| 51 | PACKAGECONFIG[gl] = "--enable-gl,--disable-gl,mesa-glut" |
| 52 | |
| 53 | PACKAGES =+ "${PN}-gif2webp" |
| 54 | |
| 55 | DESCRIPTION_${PN}-gif2webp = "Simple tool to convert animated GIFs to WebP" |
| 56 | FILES_${PN}-gif2webp = "${bindir}/gif2webp" |