Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 1 | SUMMARY = "A password/passphrase strength checking and enforcement toolset" |
| 2 | DESCRIPTION = "\ |
| 3 | passwdqc is a password/passphrase strength checking and policy enforcement \ |
| 4 | toolset, including an optional PAM module (pam_passwdqc), command-line \ |
| 5 | programs (pwqcheck and pwqgen), and a library (libpasswdqc). \ |
| 6 | pam_passwdqc is normally invoked on password changes by programs such as \ |
| 7 | passwd(1). It is capable of checking password or passphrase strength, \ |
| 8 | enforcing a policy, and offering randomly-generated passphrases, with \ |
| 9 | all of these features being optional and easily (re-)configurable. \ |
| 10 | \ |
| 11 | pwqcheck and pwqgen are standalone password/passphrase strength checking \ |
| 12 | and random passphrase generator programs, respectively, which are usable \ |
| 13 | from scripts. \ |
| 14 | \ |
| 15 | libpasswdqc is the underlying library, which may also be used from \ |
| 16 | third-party programs. \ |
| 17 | " |
| 18 | |
| 19 | HOMEPAGE = "http://www.openwall.com/passwdqc" |
| 20 | SECTION = "System Environment/Base" |
| 21 | |
| 22 | DEPENDS += "libpam" |
| 23 | |
Brad Bishop | 8410d61 | 2019-11-25 09:40:59 -0500 | [diff] [blame] | 24 | inherit features_check |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 25 | REQUIRED_DISTRO_FEATURES = "pam" |
| 26 | |
Brad Bishop | 2d39a06 | 2019-10-28 08:33:36 -0400 | [diff] [blame] | 27 | LICENSE = "BSD-1-Clause" |
Andrew Geissler | 87f5cff | 2022-09-30 13:13:31 -0500 | [diff] [blame] | 28 | LIC_FILES_CHKSUM = "file://LICENSE;md5=ac99c8678577a1c2f9f04cccee411d5d" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 29 | |
| 30 | SRC_URI = "http://www.openwall.com/${BPN}/${BP}.tar.gz \ |
| 31 | file://makefile-add-ldflags.patch \ |
| 32 | " |
Andrew Geissler | 87f5cff | 2022-09-30 13:13:31 -0500 | [diff] [blame] | 33 | SRC_URI[sha256sum] = "ff1f505764c020f6a4484b1e0cc4fdbf2e3f71b522926d90b4709104ca0604ab" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 34 | |
| 35 | # explicitly define LINUX_PAM in case DISTRO_FEATURES no pam |
| 36 | # this package's pam_passwdqc.so needs pam |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 37 | CFLAGS:append = " -Wall -fPIC -DHAVE_SHADOW -DLINUX_PAM" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 38 | |
| 39 | # -e is no longer default setting in bitbake.conf |
| 40 | EXTRA_OEMAKE = "-e" |
| 41 | |
| 42 | do_compile() { |
| 43 | # make sure sub make use environment to override variables in Makefile |
| 44 | # Linux) $(MAKE), there is a tab between |
| 45 | sed -i -e 's/Linux) $(MAKE) CFLAGS_lib/Linux) $(MAKE) -e CFLAGS_lib/' ${S}/Makefile |
| 46 | |
| 47 | # LD_lib and LD must be CC because of Makefile |
| 48 | oe_runmake LD="${CC}" |
| 49 | } |
| 50 | |
| 51 | do_install() { |
| 52 | oe_runmake install DESTDIR=${D} SHARED_LIBDIR=${base_libdir} \ |
| 53 | DEVEL_LIBDIR=${libdir} SECUREDIR=${base_libdir}/security \ |
| 54 | INSTALL="install -p" |
| 55 | } |
| 56 | |
| 57 | PROVIDES += "pam-${BPN}" |
| 58 | PACKAGES =+ "lib${BPN} pam-${BPN}" |
| 59 | |
Andrew Geissler | 87f5cff | 2022-09-30 13:13:31 -0500 | [diff] [blame] | 60 | FILES:lib${BPN} = "${base_libdir}/libpasswdqc.so.1" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 61 | FILES:pam-${BPN} = "${base_libdir}/security/pam_passwdqc.so" |
| 62 | FILES:${PN}-dbg += "${base_libdir}/security/.debug" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 63 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 64 | RDEPENDS:${PN} = "lib${BPN} pam-${BPN}" |
| 65 | RDEPENDS:pam-${BPN} = "lib${BPN}" |