blob: d29195545fd8f9bfbd8bdb426ff77709f8763330 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Python interface to libarchive"
2DESCRIPTION = "A Python interface to libarchive. It uses the standard ctypes module to \
3 dynamically load and access the C library."
4HOMEPAGE = "https://github.com/Changaco/python-libarchive-c"
5LICENSE = "CC0-1.0"
6LIC_FILES_CHKSUM = "file://LICENSE.md;md5=bcab380227a83bc147350b40a81e6ffc"
7
8PYPI_PACKAGE = "libarchive-c"
9
10inherit pypi setuptools3
11
William A. Kennington IIIac69b482021-06-02 12:28:27 -070012SRC_URI[md5sum] = "920885f5910aa8245e30896996e0415b"
13SRC_URI[sha256sum] = "6f12fa9cf0e44579e5f45bbf11aa455a930fbfdb13ea0ce3c3dfe7b9b9a452ba"
Andrew Geissler82c905d2020-04-13 13:39:40 -050014
Andrew Geissler475cb722020-07-10 16:00:51 -050015RDEPENDS_${PN} += "\
16 libarchive \
17 ${PYTHON_PN}-ctypes \
18 ${PYTHON_PN}-mmap \
19"
Andrew Geissler82c905d2020-04-13 13:39:40 -050020
21BBCLASSEXTEND = "native"