Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "Python interface to libarchive" |
| 2 | DESCRIPTION = "A Python interface to libarchive. It uses the standard ctypes module to \ |
| 3 | dynamically load and access the C library." |
| 4 | HOMEPAGE = "https://github.com/Changaco/python-libarchive-c" |
| 5 | LICENSE = "CC0-1.0" |
| 6 | LIC_FILES_CHKSUM = "file://LICENSE.md;md5=bcab380227a83bc147350b40a81e6ffc" |
| 7 | |
| 8 | PYPI_PACKAGE = "libarchive-c" |
| 9 | |
| 10 | inherit pypi setuptools3 |
| 11 | |
William A. Kennington III | ac69b48 | 2021-06-02 12:28:27 -0700 | [diff] [blame] | 12 | SRC_URI[md5sum] = "920885f5910aa8245e30896996e0415b" |
| 13 | SRC_URI[sha256sum] = "6f12fa9cf0e44579e5f45bbf11aa455a930fbfdb13ea0ce3c3dfe7b9b9a452ba" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 14 | |
Andrew Geissler | 475cb72 | 2020-07-10 16:00:51 -0500 | [diff] [blame] | 15 | RDEPENDS_${PN} += "\ |
| 16 | libarchive \ |
| 17 | ${PYTHON_PN}-ctypes \ |
| 18 | ${PYTHON_PN}-mmap \ |
| 19 | " |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 20 | |
| 21 | BBCLASSEXTEND = "native" |