Michael Shen | cf7d39d | 2021-08-05 10:14:46 +0800 | [diff] [blame^] | 1 | SUMMARY = "GPIO control library for bash scripts" |
2 | DESCRIPTION = "GPIO control library for bash scripts." | ||||
3 | LICENSE = "Apache-2.0" | ||||
4 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10" | ||||
5 | PR = "r1" | ||||
6 | |||||
7 | SRC_URI += "file://lib.sh" | ||||
8 | |||||
9 | RDEPENDS_${PN} = "bash" | ||||
10 | |||||
11 | do_install() { | ||||
12 | install -d ${D}${datadir}/gpio-ctrl | ||||
13 | install -m 0755 ${WORKDIR}/lib.sh ${D}${datadir}/gpio-ctrl/ | ||||
14 | } |