Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 1 | SUMMARY = "Pixman: Pixel Manipulation library" |
| 2 | |
| 3 | DESCRIPTION = "Pixman provides a library for manipulating pixel regions \ |
| 4 | -- a set of Y-X banded rectangles, image compositing using the \ |
| 5 | Porter/Duff model and implicit mask generation for geometric primitives \ |
| 6 | including trapezoids, triangles, and rectangles." |
| 7 | |
| 8 | require xorg-lib-common.inc |
| 9 | |
| 10 | # see http://cairographics.org/releases/ - only even minor versions are stable |
| 11 | UPSTREAM_CHECK_REGEX = "pixman-(?P<pver>\d+\.(\d*[02468])+(\.\d+)+)" |
| 12 | |
| 13 | LICENSE = "MIT & MIT-style & PD" |
| 14 | LIC_FILES_CHKSUM = "file://COPYING;md5=14096c769ae0cbb5fcb94ec468be11b3 \ |
| 15 | file://pixman/pixman-matrix.c;endline=25;md5=ba6e8769bfaaee2c41698755af04c4be \ |
| 16 | file://pixman/pixman-arm-neon-asm.h;endline=24;md5=9a9cc1e51abbf1da58f4d9528ec9d49b \ |
| 17 | " |
| 18 | DEPENDS += "zlib libpng" |
| 19 | BBCLASSEXTEND = "native nativesdk" |
| 20 | |
| 21 | PE = "1" |
| 22 | |
| 23 | IWMMXT = "--disable-arm-iwmmxt" |
| 24 | LOONGSON_MMI = "--disable-loongson-mmi" |
| 25 | # If target supports neon then disable the 'simd' (ie VFPv2) fallback, otherwise disable neon. |
| 26 | NEON = "${@bb.utils.contains("TUNE_FEATURES", "neon", "--disable-arm-simd", "--disable-arm-neon" ,d)}" |
| 27 | |
| 28 | EXTRA_OECONF = "--disable-gtk ${IWMMXT} ${LOONGSON_MMI} ${NEON}" |
| 29 | EXTRA_OECONF_class-native = "--disable-gtk" |
| 30 | EXTRA_OECONF_class-nativesdk = "--disable-gtk" |
| 31 | |
| 32 | SRC_URI += "\ |
| 33 | file://0001-ARM-qemu-related-workarounds-in-cpu-features-detecti.patch \ |
| 34 | file://asm_include.patch \ |
| 35 | file://0001-test-utils-Check-for-FE_INVALID-definition-before-us.patch \ |
| 36 | " |
| 37 | |
| 38 | SRC_URI[md5sum] = "002a4fcb644ddfcb4b0e4191576a0d59" |
| 39 | SRC_URI[sha256sum] = "39ba3438f3d17c464b0cb8be006dacbca0ab5aee97ebde69fec7ecdbf85794a0" |
| 40 | |
| 41 | REQUIRED_DISTRO_FEATURES = "" |