Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 1 | SECTION = "devel" |
| 2 | SUMMARY = "Linux Trace Toolkit KERNEL MODULE" |
| 3 | DESCRIPTION = "The lttng-modules 2.0 package contains the kernel tracer modules" |
| 4 | LICENSE = "LGPLv2.1 & GPLv2 & MIT" |
Brad Bishop | 0011132 | 2018-04-01 22:23:53 -0400 | [diff] [blame] | 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=c4613d1f8a9587bd7b366191830364b3 \ |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 6 | file://gpl-2.0.txt;md5=751419260aa954499f7abaabaa882bbe \ |
Brad Bishop | 0011132 | 2018-04-01 22:23:53 -0400 | [diff] [blame] | 7 | file://lgpl-2.1.txt;md5=243b725d71bb5df4a1e5920b344b86ad \ |
| 8 | " |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 9 | |
| 10 | inherit module |
| 11 | |
| 12 | COMPATIBLE_HOST = '(x86_64|i.86|powerpc|aarch64|mips|nios2|arm).*-linux' |
| 13 | |
| 14 | SRC_URI = "https://lttng.org/files/${BPN}/${BPN}-${PV}.tar.bz2 \ |
| 15 | file://Makefile-Do-not-fail-if-CONFIG_TRACEPOINTS-is-not-en.patch \ |
| 16 | file://BUILD_RUNTIME_BUG_ON-vs-gcc7.patch \ |
| 17 | " |
| 18 | |
Brad Bishop | d5ae7d9 | 2018-06-14 09:52:03 -0700 | [diff] [blame] | 19 | SRC_URI[md5sum] = "8110099f4615fc89a74ffe9189b56cfc" |
| 20 | SRC_URI[sha256sum] = "04a080c81743eb29d181bac29ceb0c15819a2f4210793f2cc9958d885435029f" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 21 | |
| 22 | export INSTALL_MOD_DIR="kernel/lttng-modules" |
| 23 | |
| 24 | EXTRA_OEMAKE += "KERNELDIR='${STAGING_KERNEL_DIR}'" |
| 25 | |
| 26 | do_install_append() { |
| 27 | # Delete empty directories to avoid QA failures if no modules were built |
| 28 | find ${D}/${nonarch_base_libdir} -depth -type d -empty -exec rmdir {} \; |
| 29 | } |
| 30 | |
| 31 | python do_package_prepend() { |
| 32 | if not os.path.exists(os.path.join(d.getVar('D'), d.getVar('nonarch_base_libdir')[1:], 'modules')): |
| 33 | bb.warn("%s: no modules were created; this may be due to CONFIG_TRACEPOINTS not being enabled in your kernel." % d.getVar('PN')) |
| 34 | } |
| 35 | |