Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "wolfSSL Lightweight Embedded SSL/TLS Library" |
| 2 | DESCRIPTION = "wolfSSL, formerly CyaSSL, is a lightweight SSL library written \ |
| 3 | in C and optimized for embedded and RTOS environments. It can \ |
| 4 | be up to 20 times smaller than OpenSSL while still supporting \ |
| 5 | a full TLS client and server, up to TLS 1.3" |
| 6 | HOMEPAGE = "https://www.wolfssl.com/products/wolfssl" |
| 7 | BUGTRACKER = "https://github.com/wolfssl/wolfssl/issues" |
| 8 | SECTION = "libs" |
| 9 | LICENSE = "GPLv2" |
| 10 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
| 11 | |
| 12 | PROVIDES += "cyassl" |
| 13 | RPROVIDES_${PN} = "cyassl" |
| 14 | |
Andrew Geissler | a2681d9 | 2020-10-16 10:17:07 -0500 | [diff] [blame] | 15 | SRC_URI = "git://github.com/wolfSSL/wolfssl.git;protocol=https \ |
Andrew Geissler | a2681d9 | 2020-10-16 10:17:07 -0500 | [diff] [blame] | 16 | " |
Andrew Geissler | 97771a3 | 2021-03-05 15:23:11 -0600 | [diff] [blame] | 17 | SRCREV = "830de9a9fb99e30f9ac9caa0a7f7bba29c3b4863" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 18 | S = "${WORKDIR}/git" |
| 19 | |
| 20 | inherit autotools |
| 21 | |
| 22 | BBCLASSEXTEND += "native nativesdk" |