blob: 83406f50773363e3a43770fc3262a4e9236d02c2 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "wolfSSL Lightweight Embedded SSL/TLS Library"
2DESCRIPTION = "wolfSSL, formerly CyaSSL, is a lightweight SSL library written \
3 in C and optimized for embedded and RTOS environments. It can \
4 be up to 20 times smaller than OpenSSL while still supporting \
5 a full TLS client and server, up to TLS 1.3"
6HOMEPAGE = "https://www.wolfssl.com/products/wolfssl"
7BUGTRACKER = "https://github.com/wolfssl/wolfssl/issues"
8SECTION = "libs"
9LICENSE = "GPLv2"
10LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
11
12PROVIDES += "cyassl"
13RPROVIDES_${PN} = "cyassl"
14
Andrew Geisslera2681d92020-10-16 10:17:07 -050015SRC_URI = "git://github.com/wolfSSL/wolfssl.git;protocol=https \
Andrew Geisslera2681d92020-10-16 10:17:07 -050016"
Andrew Geissler97771a32021-03-05 15:23:11 -060017SRCREV = "830de9a9fb99e30f9ac9caa0a7f7bba29c3b4863"
Andrew Geissler82c905d2020-04-13 13:39:40 -050018S = "${WORKDIR}/git"
19
20inherit autotools
21
22BBCLASSEXTEND += "native nativesdk"