Brad Bishop | 2d39a06 | 2019-10-28 08:33:36 -0400 | [diff] [blame] | 1 | SUMMARY = "Help browser for the GNOME desktop" |
| 2 | LICENSE = "GPLv2" |
| 3 | LIC_FILES_CHKSUM = " \ |
| 4 | file://COPYING;md5=6e1b9cb787e76d7e6946887a65caa754 \ |
| 5 | " |
| 6 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 7 | inherit gnomebase itstool autotools-brokensep gsettings gettext gtk-doc features_check mime-xdg |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 8 | |
| 9 | # for webkitgtk |
| 10 | REQUIRED_DISTRO_FEATURES = "x11" |
Brad Bishop | 2d39a06 | 2019-10-28 08:33:36 -0400 | [diff] [blame] | 11 | |
Andrew Geissler | 6972109 | 2021-07-23 12:57:00 -0400 | [diff] [blame] | 12 | SRC_URI[archive.sha256sum] = "a173847851f26189be78ecbb10015d539d8cceffc7c23e8635492bc3ada5ee23" |
Brad Bishop | 2d39a06 | 2019-10-28 08:33:36 -0400 | [diff] [blame] | 13 | |
| 14 | DEPENDS += " \ |
| 15 | libxml2-native \ |
| 16 | glib-2.0-native \ |
Brad Bishop | 2d39a06 | 2019-10-28 08:33:36 -0400 | [diff] [blame] | 17 | gtk+3 \ |
| 18 | appstream-glib \ |
| 19 | libxslt \ |
| 20 | sqlite3 \ |
| 21 | webkitgtk \ |
| 22 | yelp-xsl \ |
| 23 | " |
| 24 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 25 | do_configure:prepend() { |
Brad Bishop | 2d39a06 | 2019-10-28 08:33:36 -0400 | [diff] [blame] | 26 | export ITSTOOL=${STAGING_BINDIR_NATIVE}/itstool |
| 27 | } |
| 28 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 29 | FILES:${PN} += " \ |
Brad Bishop | 2d39a06 | 2019-10-28 08:33:36 -0400 | [diff] [blame] | 30 | ${datadir}/metainfo \ |
| 31 | ${datadir}/yelp-xsl \ |
| 32 | " |
| 33 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 34 | RDEPENDS:${PN} += "yelp-xsl" |