Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | SUMMARY = "pkgconf provides compiler and linker configuration for development frameworks." |
| 2 | DESCRIPTION = "pkgconf is a program which helps to configure compiler and linker \ |
| 3 | flags for development frameworks. It is similar to pkg-config from \ |
| 4 | freedesktop.org, providing additional functionality while also maintaining \ |
| 5 | compatibility." |
| 6 | HOMEPAGE = "http://pkgconf.org" |
| 7 | BUGTRACKER = "https://github.com/pkgconf/pkgconf/issues" |
| 8 | SECTION = "devel" |
| 9 | PROVIDES += "pkgconfig" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 10 | RPROVIDES:${PN} += "pkgconfig" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 11 | |
| 12 | # The pkgconf license seems to be functionally equivalent to BSD-2-Clause or |
| 13 | # ISC, but has different wording, so needs its own name. |
| 14 | LICENSE = "pkgconf" |
| 15 | LIC_FILES_CHKSUM = "file://COPYING;md5=2214222ec1a820bd6cc75167a56925e0" |
| 16 | |
| 17 | SRC_URI = "\ |
| 18 | https://distfiles.dereferenced.org/pkgconf/pkgconf-${PV}.tar.xz \ |
| 19 | file://pkg-config-wrapper \ |
| 20 | file://pkg-config-native.in \ |
| 21 | file://pkg-config-esdk.in \ |
| 22 | " |
Andrew Geissler | d159c7f | 2021-09-02 21:05:58 -0500 | [diff] [blame^] | 23 | SRC_URI[sha256sum] = "ef9c7e61822b7cb8356e6e9e1dca58d9556f3200d78acab35e4347e9d4c2bbaf" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 24 | |
| 25 | inherit autotools |
| 26 | |
| 27 | EXTRA_OECONF += "--with-pkg-config-dir='${libdir}/pkgconfig:${datadir}/pkgconfig'" |
| 28 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 29 | do_install:append () { |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 30 | # Install a wrapper which deals, as much as possible with pkgconf vs |
| 31 | # pkg-config compatibility issues. |
| 32 | install -m 0755 "${WORKDIR}/pkg-config-wrapper" "${D}${bindir}/pkg-config" |
| 33 | } |
| 34 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 35 | do_install:append:class-native () { |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 36 | # Install a pkg-config-native wrapper that will use the native sysroot instead |
| 37 | # of the MACHINE sysroot, for using pkg-config when building native tools. |
| 38 | sed -e "s|@PATH_NATIVE@|${PKG_CONFIG_PATH}|" \ |
| 39 | < ${WORKDIR}/pkg-config-native.in > ${B}/pkg-config-native |
| 40 | install -m755 ${B}/pkg-config-native ${D}${bindir}/pkg-config-native |
| 41 | sed -e "s|@PATH_NATIVE@|${PKG_CONFIG_PATH}|" \ |
| 42 | -e "s|@LIBDIR_NATIVE@|${PKG_CONFIG_LIBDIR}|" \ |
| 43 | < ${WORKDIR}/pkg-config-esdk.in > ${B}/pkg-config-esdk |
| 44 | install -m755 ${B}/pkg-config-esdk ${D}${bindir}/pkg-config-esdk |
| 45 | } |
| 46 | |
| 47 | # When using the RPM generated automatic package dependencies, some packages |
| 48 | # will end up requiring 'pkgconfig(pkg-config)'. Allow this behavior by |
| 49 | # specifying an appropriate provide. |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 50 | RPROVIDES:${PN} += "pkgconfig(pkg-config)" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 51 | |
| 52 | # Include pkg.m4 in the main package, leaving libpkgconf dev files in -dev |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 53 | FILES:${PN}-dev:remove = "${datadir}/aclocal" |
| 54 | FILES:${PN} += "${datadir}/aclocal" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 55 | |
| 56 | BBCLASSEXTEND += "native nativesdk" |
| 57 | |
| 58 | pkgconf_sstate_fixup_esdk () { |
| 59 | if [ "${BB_CURRENTTASK}" = "populate_sysroot_setscene" -a "${WITHIN_EXT_SDK}" = "1" ] ; then |
| 60 | pkgconfdir="${SSTATE_INSTDIR}/recipe-sysroot-native/${bindir_native}" |
| 61 | mv $pkgconfdir/pkg-config $pkgconfdir/pkg-config.real |
| 62 | lnr $pkgconfdir/pkg-config-esdk $pkgconfdir/pkg-config |
| 63 | sed -i -e "s|^pkg-config|pkg-config.real|" $pkgconfdir/pkg-config-native |
| 64 | fi |
| 65 | } |
| 66 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 67 | SSTATEPOSTUNPACKFUNCS:append:class-native = " pkgconf_sstate_fixup_esdk" |