Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 1 | SUMMARY = "Text shaping library" |
| 2 | DESCRIPTION = "HarfBuzz is an OpenType text shaping engine." |
| 3 | HOMEPAGE = "http://www.freedesktop.org/wiki/Software/HarfBuzz" |
| 4 | BUGTRACKER = "https://bugs.freedesktop.org/enter_bug.cgi?product=HarfBuzz" |
| 5 | SECTION = "libs" |
| 6 | LICENSE = "MIT" |
Andrew Geissler | 5a43b43 | 2020-06-13 10:46:56 -0500 | [diff] [blame] | 7 | LIC_FILES_CHKSUM = "file://COPYING;md5=8f787620b7d3866d9552fd1924c07572 \ |
Brad Bishop | 79641f2 | 2019-09-10 07:20:22 -0400 | [diff] [blame] | 8 | file://src/hb-ucd.cc;beginline=1;endline=15;md5=29d4dcb6410429195df67efe3382d8bc" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 9 | |
Andrew Geissler | 5a43b43 | 2020-06-13 10:46:56 -0500 | [diff] [blame] | 10 | UPSTREAM_CHECK_URI = "https://github.com/${BPN}/${BPN}/releases" |
| 11 | UPSTREAM_CHECK_REGEX = "harfbuzz-(?P<pver>\d+(\.\d+)+).tar" |
| 12 | |
| 13 | SRC_URI = "https://github.com/${BPN}/${BPN}/releases/download/${PV}/${BPN}-${PV}.tar.xz" |
Andrew Geissler | 635e0e4 | 2020-08-21 15:58:33 -0500 | [diff] [blame] | 14 | SRC_URI[sha256sum] = "e95ee43b6bd0d3d1307e2aacf0f9c0050e5baceb21988b367b833028114aa569" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 15 | |
| 16 | inherit autotools pkgconfig lib_package gtk-doc |
| 17 | |
Brad Bishop | f3f93bb | 2019-10-16 14:33:32 -0400 | [diff] [blame] | 18 | PACKAGECONFIG ??= "cairo fontconfig freetype glib icu" |
| 19 | PACKAGECONFIG[cairo] = "--with-cairo,--without-cairo,cairo" |
| 20 | PACKAGECONFIG[fontconfig] = "--with-fontconfig,--without-fontconfig,fontconfig" |
| 21 | PACKAGECONFIG[freetype] = "--with-freetype,--without-freetype,freetype" |
| 22 | PACKAGECONFIG[glib] = "--with-glib,--without-glib,glib-2.0" |
Brad Bishop | 79641f2 | 2019-09-10 07:20:22 -0400 | [diff] [blame] | 23 | PACKAGECONFIG[graphite] = "--with-graphite2,--without-graphite2,graphite2" |
Brad Bishop | f3f93bb | 2019-10-16 14:33:32 -0400 | [diff] [blame] | 24 | PACKAGECONFIG[icu] = "--with-icu,--without-icu,icu" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 25 | |
Brad Bishop | 1d80a2e | 2019-11-15 16:35:03 -0500 | [diff] [blame] | 26 | PACKAGES =+ "${PN}-icu ${PN}-icu-dev ${PN}-subset" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 27 | |
| 28 | LEAD_SONAME = "libharfbuzz.so" |
| 29 | |
Brad Bishop | f3f93bb | 2019-10-16 14:33:32 -0400 | [diff] [blame] | 30 | do_install_append() { |
| 31 | # If no tools are installed due to PACKAGECONFIG then this directory is |
| 32 | #still installed, so remove it to stop packaging wanings. |
| 33 | rmdir --ignore-fail-on-non-empty ${D}${bindir} |
| 34 | } |
| 35 | |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 36 | FILES_${PN}-icu = "${libdir}/libharfbuzz-icu.so.*" |
| 37 | FILES_${PN}-icu-dev = "${libdir}/libharfbuzz-icu.la \ |
| 38 | ${libdir}/libharfbuzz-icu.so \ |
| 39 | ${libdir}/pkgconfig/harfbuzz-icu.pc \ |
| 40 | " |
Brad Bishop | 1d80a2e | 2019-11-15 16:35:03 -0500 | [diff] [blame] | 41 | FILES_${PN}-subset = "${libdir}/libharfbuzz-subset.so.*" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 42 | |
| 43 | BBCLASSEXTEND = "native nativesdk" |