Brad Bishop | 6a62e0e | 2019-10-21 08:11:42 -0400 | [diff] [blame] | 1 | SUMMARY = "Multimedia processing server for Linux" |
| 2 | AUTHOR = "Wim Taymans <wtaymans@redhat.com>" |
| 3 | HOMEPAGE = "https://pipewire.org" |
| 4 | SECTION = "multimedia" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 5 | LICENSE = "MIT" |
Brad Bishop | 6a62e0e | 2019-10-21 08:11:42 -0400 | [diff] [blame] | 6 | LIC_FILES_CHKSUM = " \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 7 | file://LICENSE;md5=e2c0b7d86d04e716a3c4c9ab34260e69 \ |
| 8 | file://COPYING;md5=97be96ca4fab23e9657ffa590b931c1a \ |
Brad Bishop | 6a62e0e | 2019-10-21 08:11:42 -0400 | [diff] [blame] | 9 | " |
| 10 | DEPENDS = "alsa-lib dbus udev" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 11 | SRCREV = "74a1632f0720886d5b3b6c23ee8fcd6c03ca7aac" |
| 12 | PV = "0.3.1" |
Brad Bishop | 6a62e0e | 2019-10-21 08:11:42 -0400 | [diff] [blame] | 13 | |
| 14 | SRC_URI = "git://github.com/PipeWire/pipewire" |
| 15 | |
| 16 | S = "${WORKDIR}/git" |
| 17 | |
| 18 | inherit meson pkgconfig systemd manpages |
| 19 | |
| 20 | PACKAGECONFIG ??= "\ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 21 | ${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', 'bluez', '', d)} \ |
| 22 | ${@bb.utils.filter('DISTRO_FEATURES', 'pulseaudio systemd vulkan', d)} \ |
| 23 | jack gstreamer \ |
Brad Bishop | 6a62e0e | 2019-10-21 08:11:42 -0400 | [diff] [blame] | 24 | " |
| 25 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 26 | PACKAGECONFIG[bluez] = "-Dbluez5=true,-Dbluez5=false,bluez5 sbc" |
| 27 | PACKAGECONFIG[jack] = "-Djack=true,-Djack=false,jack" |
| 28 | PACKAGECONFIG[gstreamer] = "-Dgstreamer=true,-Dgstreamer=false,glib-2.0 gstreamer1.0 gstreamer1.0-plugins-base" |
Brad Bishop | 6a62e0e | 2019-10-21 08:11:42 -0400 | [diff] [blame] | 29 | PACKAGECONFIG[manpages] = "-Dman=true,-Dman=false,libxml-parser-perl-native" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 30 | PACKAGECONFIG[pulseaudio] = "-Dpipewire-pulseaudio=true,-Dpipewire-pulseaudio=false,pulseaudio" |
| 31 | PACKAGECONFIG[systemd] = "-Dsystemd=true,-Dsystemd=false,systemd" |
| 32 | PACKAGECONFIG[vulkan] = "-Dvulkan=true,-Dvulkan=false,vulkan-loader" |
| 33 | |
| 34 | LDFLAGS_append_mipsarch = " -latomic" |
| 35 | LDFLAGS_append_x86 = " -latomic" |
Brad Bishop | 6a62e0e | 2019-10-21 08:11:42 -0400 | [diff] [blame] | 36 | |
| 37 | PACKAGES =+ "\ |
| 38 | ${PN}-spa-plugins \ |
| 39 | ${PN}-alsa \ |
| 40 | ${PN}-config \ |
| 41 | gstreamer1.0-${PN} \ |
| 42 | lib${PN} \ |
| 43 | lib${PN}-modules \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 44 | lib${PN}-jack \ |
Brad Bishop | 6a62e0e | 2019-10-21 08:11:42 -0400 | [diff] [blame] | 45 | " |
| 46 | |
| 47 | RDEPENDS_lib${PN} += "lib${PN}-modules ${PN}-spa-plugins" |
| 48 | |
| 49 | FILES_${PN} = "\ |
| 50 | ${sysconfdir}/pipewire/pipewire.conf \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 51 | ${bindir}/pw-* \ |
Brad Bishop | 6a62e0e | 2019-10-21 08:11:42 -0400 | [diff] [blame] | 52 | ${bindir}/pipewire* \ |
| 53 | ${systemd_user_unitdir}/* \ |
| 54 | " |
| 55 | FILES_lib${PN} = "\ |
| 56 | ${libdir}/libpipewire-*.so.* \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 57 | ${libdir}/libjack-*.so.* \ |
| 58 | ${libdir}/libpulse-*.so.* \ |
Brad Bishop | 6a62e0e | 2019-10-21 08:11:42 -0400 | [diff] [blame] | 59 | " |
| 60 | FILES_lib${PN}-modules = "\ |
| 61 | ${libdir}/pipewire-*/* \ |
| 62 | " |
| 63 | FILES_${PN}-spa-plugins = "\ |
| 64 | ${bindir}/spa-* \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 65 | ${libdir}/spa-*/* \ |
Brad Bishop | 6a62e0e | 2019-10-21 08:11:42 -0400 | [diff] [blame] | 66 | " |
| 67 | FILES_${PN}-alsa = "\ |
| 68 | ${libdir}/alsa-lib/* \ |
Brad Bishop | 6a62e0e | 2019-10-21 08:11:42 -0400 | [diff] [blame] | 69 | " |
| 70 | FILES_gstreamer1.0-${PN} = "\ |
| 71 | ${libdir}/gstreamer-1.0/* \ |
| 72 | " |
| 73 | |
| 74 | CONFFILES_${PN} = "\ |
| 75 | ${sysconfdir}/pipewire/pipewire.conf \ |
| 76 | " |