Andrew Geissler | d1e8949 | 2021-02-12 15:35:20 -0600 | [diff] [blame^] | 1 | SUMMARY = "a fast C/C++ compiler cache" |
| 2 | DESCRIPTION = "ccache is a compiler cache. It speeds up recompilation \ |
| 3 | by caching the result of previous compilations and detecting when the \ |
| 4 | same compilation is being done again. Supported languages are C, C\+\+, \ |
| 5 | Objective-C and Objective-C++." |
| 6 | HOMEPAGE = "http://ccache.samba.org" |
| 7 | SECTION = "devel" |
| 8 | |
| 9 | LICENSE = "GPLv3+" |
| 10 | LIC_FILES_CHKSUM = "file://LICENSE.adoc;md5=a66c581f855c1c408730fe5d171e3013" |
| 11 | |
| 12 | DEPENDS = "zstd" |
| 13 | |
| 14 | SRC_URI = "https://github.com/ccache/ccache/releases/download/v${PV}/${BP}.tar.gz \ |
| 15 | file://0001-Improve-SIMD-detection-735.patch \ |
| 16 | file://0002-Always-use-64bit-to-print-time_t.patch \ |
| 17 | file://0001-blake3-Remove-asm-checks-for-sse-avx.patch \ |
| 18 | " |
| 19 | SRC_URI[sha256sum] = "cdeefb827b3eef3b42b5454858123881a4a90abbd46cc72cf8c20b3bd039deb7" |
| 20 | |
| 21 | UPSTREAM_CHECK_URI = "https://github.com/ccache/ccache/releases/" |
| 22 | |
| 23 | inherit cmake |
| 24 | |
| 25 | PATCHTOOL = "patch" |
| 26 | |
| 27 | BBCLASSEXTEND = "native nativesdk" |