Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 1 | LICENSE = "LGPLv2.1 & GPLv2" |
| 2 | LIC_FILES_CHKSUM = "file://LICENSE.LGPL2.1;md5=4fbd65380cdd255951079008b364516c \ |
| 3 | file://LICENSE.GPL2;md5=751419260aa954499f7abaabaa882bbe" |
| 4 | |
| 5 | SRC_URI = "git://github.com/systemd/systemd-bootchart.git;protocol=https \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 6 | file://0001-architecture-Recognise-RISCV-32-RISCV-64.patch \ |
| 7 | file://mips64.patch \ |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 8 | " |
| 9 | |
| 10 | SRC_URI_append_libc-musl = " \ |
| 11 | file://0001-comparison_fn_t-is-glibc-specific-use-raw-signature-.patch \ |
| 12 | file://0002-musl-does-not-provide-printf-h.patch \ |
| 13 | file://0003-musl-does-not-provide-canonicalize_file_name.patch \ |
| 14 | " |
| 15 | |
| 16 | |
Andrew Geissler | d1e8949 | 2021-02-12 15:35:20 -0600 | [diff] [blame^] | 17 | SRCREV = "8183cfd9dad8beca5434d625cf6b2df87775e956" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 18 | |
| 19 | S = "${WORKDIR}/git" |
| 20 | |
| 21 | DEPENDS = "systemd libxslt-native xmlto-native docbook-xml-dtd4-native docbook-xsl-stylesheets-native intltool" |
| 22 | |
Brad Bishop | 6dbb316 | 2019-11-25 09:41:34 -0500 | [diff] [blame] | 23 | inherit pkgconfig autotools systemd features_check |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 24 | |
| 25 | REQUIRED_DISTRO_FEATURES = "systemd" |
| 26 | |
| 27 | SYSTEMD_SERVICE_${PN} = "systemd-bootchart.service" |
| 28 | |
| 29 | do_configure_prepend() { |
| 30 | # intltool.m4 is a soft link to /usr/share/aclocal/m4, delete it and use the one in our sysroot |
| 31 | rm -f ${S}/m4/intltool.m4 |
| 32 | } |
| 33 | |
| 34 | FILES_${PN} += "${systemd_unitdir}/systemd-bootchart" |
| 35 | |
Brad Bishop | 79641f2 | 2019-09-10 07:20:22 -0400 | [diff] [blame] | 36 | EXTRA_OECONF = " --with-rootprefix=${root_prefix} \ |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 37 | --with-rootlibdir=${base_libdir}" |