Andrew Geissler | d1e8949 | 2021-02-12 15:35:20 -0600 | [diff] [blame^] | 1 | SUMMARY = "OpenGL / OpenGL ES Reference Compiler" |
| 2 | DESCRIPTION = "Glslang is the official reference compiler front end for the \ |
| 3 | OpenGL ES and OpenGL shading languages. It implements a strict interpretation \ |
| 4 | of the specifications for these languages. It is open and free for anyone to use, \ |
| 5 | either from a command line or programmatically." |
| 6 | SECTION = "graphics" |
| 7 | HOMEPAGE = "https://www.khronos.org/opengles/sdk/tools/Reference-Compiler" |
| 8 | LICENSE = "BSD-3-Clause & BSD-2-Clause & MIT & Apache-2.0 & GPL-3-with-bison-exception" |
| 9 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=c5ce49c0456e9b413b98a4368c378229" |
| 10 | |
| 11 | SRCREV = "c594de23cdd790d64ad5f9c8b059baae0ee2941d" |
| 12 | SRC_URI = "git://github.com/KhronosGroup/glslang.git;protocol=https" |
| 13 | UPSTREAM_CHECK_GITTAGREGEX = "^(?P<pver>\d+(\.\d+)+)$" |
| 14 | S = "${WORKDIR}/git" |
| 15 | |
| 16 | inherit cmake python3native |
| 17 | |
| 18 | EXTRA_OECMAKE = " \ |
| 19 | -DCMAKE_BUILD_TYPE=Release \ |
| 20 | -DBUILD_SHARED_LIBS=ON \ |
| 21 | -DENABLE_PCH=OFF \ |
| 22 | -DENABLE_CTEST=OFF \ |
| 23 | -DBUILD_EXTERNAL=OFF \ |
| 24 | " |
| 25 | |
| 26 | SOLIBSDEV = "glslang.so" |
| 27 | FILES_${PN} += "${libdir}/*.so" |
| 28 | |
| 29 | BBCLASSEXTEND = "native nativesdk" |