Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 1 | DESCRIPTION = "The Vulkan Samples is collection of resources to help develop optimized Vulkan applications." |
| 2 | LICENSE = "Apache-2.0" |
| 3 | |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=48aa35cefb768436223a6e7f18dc2a2a" |
| 5 | |
| 6 | SRC_URI = "gitsm://github.com/KhronosGroup/Vulkan-Samples.git \ |
| 7 | file://0001-CMakeLists.txt-do-not-hardcode-lib-as-installation-t.patch \ |
Andrew Geissler | d1e8949 | 2021-02-12 15:35:20 -0600 | [diff] [blame^] | 8 | file://debugfix.patch \ |
Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 9 | " |
| 10 | |
| 11 | UPSTREAM_CHECK_COMMITS = "1" |
Andrew Geissler | d1e8949 | 2021-02-12 15:35:20 -0600 | [diff] [blame^] | 12 | SRCREV = "524cdcd27005e7cd56e6694fa41e685519d7dbca" |
Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 13 | |
| 14 | UPSTREAM_CHECK_GITTAGREGEX = "These are not the releases you're looking for" |
| 15 | S = "${WORKDIR}/git" |
| 16 | |
| 17 | REQUIRED_DISTRO_FEATURES = 'vulkan' |
| 18 | |
| 19 | inherit cmake features_check |
| 20 | |
| 21 | FILES_${PN} += "${datadir}" |
Andrew Geissler | d1e8949 | 2021-02-12 15:35:20 -0600 | [diff] [blame^] | 22 | |
| 23 | # |
| 24 | # There is code to remove the prefix CMAKE_SOURCE_DIR from __FILENAME__ paths |
| 25 | # used for logging with LOGE in the code. We need to make this match the value we use |
| 26 | # in the debug source remapping from CFLAGS |
| 27 | # |
| 28 | EXTRA_OECMAKE += "-DCMAKE_DEBUG_SRCDIR=/usr/src/debug/${PN}/${EXTENDPE}${PV}-${PR}/" |
| 29 | # Binaries built with PCH enabled don't appear reproducible, differing results were seen |
| 30 | # from some builds depending on the point the PCH was compiled. Disable it to be |
| 31 | # deterministic |
| 32 | EXTRA_OECMAKE += "-DCMAKE_DISABLE_PRECOMPILE_HEADERS=ON" |