Andrew Geissler | c87764f | 2020-06-27 00:16:32 -0500 | [diff] [blame] | 1 | SUMMARY = "Resolve JSON Pointers in Python" |
| 2 | HOMEPAGE = "https://github.com/stefankoegl/python-json-pointer" |
| 3 | LICENSE = "BSD-3-Clause" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=32b15c843b7a329130f4e266a281ebb3" |
| 5 | |
| 6 | inherit pypi ptest setuptools3 |
| 7 | |
| 8 | SRC_URI[md5sum] = "741b98d0e693b08b5e44e0a9da5a7bb7" |
| 9 | SRC_URI[sha256sum] = "c192ba86648e05fdae4f08a17ec25180a9aef5008d973407b581798a83975362" |
| 10 | |
| 11 | RDEPENDS_${PN} += " \ |
| 12 | ${PYTHON_PN}-json \ |
| 13 | " |
| 14 | |
| 15 | BBCLASSEXTEND = "native nativesdk" |
| 16 | |
| 17 | SRC_URI += " \ |
| 18 | file://run-ptest \ |
| 19 | " |
| 20 | |
| 21 | RDEPENDS_${PN}-ptest += " \ |
| 22 | ${PYTHON_PN}-pytest \ |
| 23 | " |
| 24 | |
| 25 | do_install_ptest() { |
| 26 | cp -f ${S}/tests.py ${D}${PTEST_PATH}/ |
| 27 | } |