blob: 68bfe9716642ff6ff946f0c28d262020aea291bc [file] [log] [blame]
Andrew Geisslerc87764f2020-06-27 00:16:32 -05001SUMMARY = "Resolve JSON Pointers in Python"
2HOMEPAGE = "https://github.com/stefankoegl/python-json-pointer"
3LICENSE = "BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=32b15c843b7a329130f4e266a281ebb3"
5
6inherit pypi ptest setuptools3
7
8SRC_URI[md5sum] = "741b98d0e693b08b5e44e0a9da5a7bb7"
9SRC_URI[sha256sum] = "c192ba86648e05fdae4f08a17ec25180a9aef5008d973407b581798a83975362"
10
11RDEPENDS_${PN} += " \
12 ${PYTHON_PN}-json \
13"
14
15BBCLASSEXTEND = "native nativesdk"
16
17SRC_URI += " \
18 file://run-ptest \
19"
20
21RDEPENDS_${PN}-ptest += " \
22 ${PYTHON_PN}-pytest \
23"
24
25do_install_ptest() {
26 cp -f ${S}/tests.py ${D}${PTEST_PATH}/
27}