Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | DESCRIPTION = "Non-validating SQL parser module" |
| 2 | HOMEPAGE = "http://pypi.python.org/pypi/sqlparse" |
| 3 | SECTION = "devel/python" |
| 4 | LICENSE = "BSD" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=2b136f573f5386001ea3b7b9016222fc" |
| 6 | |
| 7 | SRC_URI += "file://0001-sqlparse-change-shebang-to-python3.patch \ |
| 8 | file://run-ptest \ |
| 9 | " |
| 10 | |
| 11 | SRC_URI[md5sum] = "423047887a3590b04dd18f8caf843a2f" |
| 12 | SRC_URI[sha256sum] = "e162203737712307dfe78860cc56c8da8a852ab2ee33750e33aeadf38d12c548" |
| 13 | |
| 14 | export BUILD_SYS |
| 15 | export HOST_SYS |
| 16 | |
| 17 | inherit pypi ptest setuptools3 |
| 18 | |
| 19 | RDEPENDS_${PN}-ptest += " \ |
| 20 | ${PYTHON_PN}-pytest \ |
| 21 | ${PYTHON_PN}-unixadmin \ |
| 22 | " |
| 23 | |
| 24 | do_install_ptest() { |
| 25 | install -d ${D}${PTEST_PATH}/tests |
| 26 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ |
| 27 | } |
| 28 | |
| 29 | BBCLASSEXTEND = "native nativesdk" |