Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | DESCRIPTION = "Tiny XML Library" |
| 2 | LICENSE = "Mini-XML-License" |
| 3 | LIC_FILES_CHKSUM = "file://COPYING;md5=a6ba38606d63bb042c5d8cfee182e120" |
| 4 | HOMEPAGE = "https://www.msweet.org/mxml/" |
| 5 | BUGTRACKER = "https://github.com/michaelrsweet/mxml/issues" |
| 6 | |
| 7 | SRC_URI = "git://github.com/michaelrsweet/mxml.git" |
| 8 | SRCREV = "ba3cca82e15a88a9cc6afb60f059288a99afc703" |
| 9 | S = "${WORKDIR}/git" |
| 10 | PV = "2.12+git${SRCPV}" |
| 11 | |
| 12 | CONFIGUREOPTS = " --prefix=${prefix} \ |
| 13 | --bindir=${bindir} \ |
| 14 | --sbindir=${sbindir} \ |
| 15 | --libexecdir=${libexecdir} \ |
| 16 | --datadir=${datadir} \ |
| 17 | --sysconfdir=${sysconfdir} \ |
| 18 | --sharedstatedir=${sharedstatedir} \ |
| 19 | --localstatedir=${localstatedir} \ |
| 20 | --libdir=${libdir} \ |
| 21 | --includedir=${includedir} \ |
| 22 | --oldincludedir=${oldincludedir} \ |
| 23 | --infodir=${infodir} \ |
| 24 | --mandir=${mandir} \ |
| 25 | --host=${TARGET_SYS} \ |
| 26 | --build=${BUILD_SYS} \ |
| 27 | ${PACKAGECONFIG_CONFARGS} \ |
| 28 | " |
| 29 | |
| 30 | do_configure() { |
| 31 | ./configure ${CONFIGUREOPTS} --enable-shared |
| 32 | } |
| 33 | |
| 34 | do_install () { |
| 35 | export DSTROOT=${D} |
| 36 | oe_runmake install |
| 37 | } |
| 38 | |
| 39 | PACKAGES += " ${PN}-bin " |
| 40 | FILES_${PN} = "${libdir}/*" |
| 41 | FILES_${PN}-bin = "${bindir}/*" |