Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 1 | SUMMARY = "System load testing utility" |
| 2 | DESCRIPTION = "Deliberately simple workload generator for POSIX systems. It \ |
| 3 | imposes a configurable amount of CPU, memory, I/O, and disk stress on the system." |
| 4 | HOMEPAGE = "https://github.com/ColinIanKing/stress-ng#readme" |
| 5 | LICENSE = "GPL-2.0-only" |
| 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
| 7 | |
| 8 | SRC_URI = "git://github.com/ColinIanKing/stress-ng.git;protocol=https;branch=master \ |
| 9 | file://0001-core-helper-remove-include-of-sys-mount.h.patch \ |
| 10 | file://0002-core-shim-remove-include-of-sys-mount.h.patch \ |
| 11 | " |
| 12 | SRCREV = "346518caffe5302f9a6d36860459c297c6968aaa" |
| 13 | S = "${WORKDIR}/git" |
| 14 | |
| 15 | DEPENDS = "coreutils-native" |
| 16 | |
| 17 | PROVIDES = "stress" |
| 18 | RPROVIDES:${PN} = "stress" |
| 19 | RREPLACES:${PN} = "stress" |
| 20 | RCONFLICTS:${PN} = "stress" |
| 21 | |
| 22 | inherit bash-completion |
| 23 | |
| 24 | do_compile:prepend() { |
| 25 | mkdir -p configs |
| 26 | touch configs/HAVE_APPARMOR |
| 27 | } |
| 28 | |
| 29 | do_install() { |
| 30 | oe_runmake DESTDIR=${D} install |
| 31 | ln -s stress-ng ${D}${bindir}/stress |
| 32 | } |