Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 1 | SUMMARY = "Universal encoding detector for Python 2 and 3" |
| 2 | HOMEPAGE = "https://pypi.org/project/chardet/" |
| 3 | LICENSE = "LGPL-2.1-only" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=a6f89e2100d9b6cdffcea4f398e37343" |
| 5 | |
| 6 | SRC_URI[sha256sum] = "0d6f53a15db4120f2b08c94f11e7d93d2c911ee118b6b30a04ec3ee8310179fa" |
| 7 | |
| 8 | # setup.py of chardet needs this. |
| 9 | DEPENDS += "${PYTHON_PN}-pytest-runner-native" |
| 10 | |
| 11 | inherit pypi setuptools3 |
| 12 | |
| 13 | PACKAGES =+ "${PN}-cli" |
| 14 | FILES:${PN}-cli += " \ |
| 15 | ${PYTHON_SITEPACKAGES_DIR}/chardet/cli \ |
| 16 | " |
| 17 | |
| 18 | RDEPENDS:${PN}-cli = "${PN} " |
| 19 | |
| 20 | RDEPENDS:${PN}:class-target += " \ |
| 21 | ${PYTHON_PN}-logging \ |
| 22 | " |
| 23 | |
| 24 | BBCLASSEXTEND = "native nativesdk" |