blob: 6e68a421c1a2f7b84f660d44f1390da6c8dc0253 [file] [log] [blame]
Brad Bishopbec4ebc2022-08-03 09:55:16 -04001FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
2
3#
4# Corstone-500 MACHINE
5#
6SRC_URI:append:corstone500 = " \
7 file://0001-armv7-adding-generic-timer-access-through-MMIO.patch \
8 file://0002-board-arm-add-corstone500-board.patch"
9
10#
11# Corstone1000 64-bit machines
12#
13DEPENDS:append:corstone1000 = " gnutls-native"
14CORSTONE1000_DEVICE_TREE:corstone1000-mps3 = "corstone1000-mps3"
15CORSTONE1000_DEVICE_TREE:corstone1000-fvp = "corstone1000-fvp"
16EXTRA_OEMAKE:append:corstone1000 = ' DEVICE_TREE=${CORSTONE1000_DEVICE_TREE}'
17
18SYSROOT_DIRS:append:corstone1000 = " /boot"
19
20SRC_URI:append:corstone1000 = " \
Patrick Williams864cc432023-02-09 14:54:44 -060021 file://0001-arm64-smccc-add-support-for-SMCCCv1.2-x0-x17-registe.patch \
22 file://0002-lib-uuid-introduce-uuid_str_to_le_bin-function.patch \
23 file://0003-arm_ffa-introduce-Arm-FF-A-low-level-driver.patch \
24 file://0004-arm_ffa-efi-unmap-RX-TX-buffers.patch \
25 file://0005-arm_ffa-introduce-armffa-command.patch \
26 file://0006-arm_ffa-introduce-the-FF-A-Sandbox-driver.patch \
27 file://0007-arm_ffa-introduce-Sandbox-test-cases-for-UCLASS_FFA.patch \
28 file://0008-arm_ffa-introduce-armffa-command-Sandbox-test.patch \
29 file://0009-arm_ffa-efi-introduce-FF-A-MM-communication.patch \
30 file://0010-arm_ffa-efi-corstone1000-enable-MM-communication.patch \
31 file://0011-efi-corstone1000-introduce-EFI-capsule-update.patch \
32 file://0012-arm-corstone1000-fix-unrecognized-filesystem-type.patch \
33 file://0013-efi_capsule-corstone1000-pass-interface-id-and-buffe.patch \
34 file://0014-efi_boottime-corstone1000-pass-interface-id-and-kern.patch \
35 file://0015-efi_loader-corstone1000-remove-guid-check-from-corst.patch \
36 file://0016-efi_loader-populate-ESRT-table-if-EFI_ESRT-config-op.patch \
37 file://0017-efi_firmware-add-get_image_info-for-corstone1000.patch \
38 file://0018-efi_loader-send-bootcomplete-message-to-secure-encla.patch \
39 file://0019-efi_loader-fix-null-pointer-exception-with-get_image.patch \
40 file://0020-arm-corstone1000-add-mmc-for-fvp.patch \
41 file://0021-corstone1000-add-compressed-kernel-support.patch \
42 file://0022-Introduce-external-sys-driver-to-device-tree.patch \
43 file://0023-Add-mhu-and-rpmsg-client-to-u-boot-device-tree.patch \
44 file://0024-arm-corstone1000-esrt-support.patch \
45 file://0025-efi_setup-discover-FF-A-bus-before-raising-EFI-start.patch \
46 file://0026-corstone1000-enable-distro-booting-command.patch \
Andrew Geissler2daf84b2023-03-31 09:57:23 -050047 file://0027-drivers-nvmxip-introduce-NVM-XIP-block-storage-emula.patch \
48 file://0028-sandbox64-fix-return-unsigned-long-in-readq.patch \
49 file://0029-sandbox64-add-support-for-NVMXIP-QSPI.patch \
50 file://0030-corstone1000-add-NVM-XIP-QSPI-device-tree-node.patch \
51 file://0031-corstone1000-enable-NVM-XIP-QSPI-flash.patch \
52 file://0032-sandbox64-add-a-test-case-for-UCLASS_NVMXIP.patch \
53 file://0033-nvmxip-provide-a-u-boot-shell-test-command.patch \
54 file://0034-corstone1000-add-fwu-metadata-store-info.patch \
55 file://0035-nvmxip-shorter-block-device-name.patch \
56 file://0036-efi_boottime-allow-to-reset-a-path-after-boot.patch \
57 file://0037-fwu_metadata-make-sure-structures-are-packed.patch \
58 file://0038-corstone1000-add-boot-index.patch \
59 file://0039-corstone1000-adjust-boot-bank-and-kernel-location.patch \
60 file://0040-corstone1000-add-nvmxip-fwu-mdata-and-gpt-options.patch \
61 file://0041-nvmxip-move-header-to-include.patch \
62 file://0042-corstone1000-set-kernel_addr-based-on-boot_idx.patch \
63 file://0043-corstone1000-boot-index-from-active.patch \
Patrick Williams975a06f2022-10-21 14:42:47 -050064 "
Brad Bishopbec4ebc2022-08-03 09:55:16 -040065
66#
67# FVP BASE
68#
Andrew Geissler2daf84b2023-03-31 09:57:23 -050069SRC_URI:append:fvp-base = " file://bootargs.cfg \
70 file://0001-Revert-vexpress64-pick-DRAM-size-from-DT.patch \
71 "
Brad Bishopbec4ebc2022-08-03 09:55:16 -040072
73#
74# FVP BASER
75#
76SRC_URI:append:fvp-baser-aemv8r64 = " \
77 file://0001-armv8-Add-ARMv8-MPU-configuration-logic.patch \
78 file://0002-vexpress64-add-MPU-memory-map-for-the-BASER_FVP.patch \
79 file://0003-armv8-Allow-disabling-exception-vectors-on-non-SPL-b.patch \
80 file://0004-armv8-ARMV8_SWITCH_TO_EL1-improvements.patch \
81 file://0005-armv8-Make-disabling-HVC-configurable-when-switching.patch \
82 file://0006-vexpress64-Do-not-set-COUNTER_FREQUENCY.patch \
83 file://0007-vexpress64-Enable-LIBFDT_OVERLAY-in-the-vexpress_aem.patch \
84 file://0008-armv8-Allow-PRBAR-MPU-attributes-to-be-configured.patch \
85 file://0009-armv8-Enable-icache-when-switching-exception-levels-.patch \
86 "
87
88
89#
90# Juno Machines
91#
Patrick Williamsb9af8752023-01-30 13:28:01 -060092SRC_URI:append:juno = " file://0001-configs-vexpress-modify-to-boot-compressed-initramfs.patch"
Brad Bishopbec4ebc2022-08-03 09:55:16 -040093
94
95#
96# TC0 and TC1 MACHINES
97#
98SRC_URI:append:tc = " \
99 file://bootargs.cfg \
100 file://0001-arm-total_compute-update-secure-dram-size.patch \
Patrick Williams8dd68482022-10-04 07:57:18 -0500101 file://0002-arm_ffa-introducing-Arm-FF-A-low-level-driver.patch \
102 file://0003-arm-total_compute-enable-psci.patch \
103 file://0004-arm_ffa-rxtx_map-should-use-64-bit-calls.patch \
104 file://0005-efi_firmware-add-new-fmp-driver-that-supports-arm-fw.patch \
105 file://0006-arm-total_compute-enable-capsule-update.patch \
106 file://0007-arm_ffa-unmap-rxtx-buffer-before-exiting-u-boot.patch \
Brad Bishopbec4ebc2022-08-03 09:55:16 -0400107 "