Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 1 | SUMMARY = "Python interface to libarchive" |
| 2 | DESCRIPTION = "A Python interface to libarchive. It uses the standard ctypes module to \ |
| 3 | dynamically load and access the C library." |
| 4 | HOMEPAGE = "https://github.com/Changaco/python-libarchive-c" |
| 5 | LICENSE = "CC0-1.0" |
| 6 | LIC_FILES_CHKSUM = "file://LICENSE.md;md5=bcab380227a83bc147350b40a81e6ffc" |
| 7 | |
| 8 | PYPI_PACKAGE = "libarchive-c" |
| 9 | |
| 10 | inherit pypi setuptools3 |
| 11 | |
| 12 | SRC_URI[sha256sum] = "21ad493f4628972fc82440bff54c834a9fbe13be3893037a4bad332b9ee741e5" |
| 13 | |
| 14 | RDEPENDS:${PN} += "\ |
| 15 | libarchive \ |
| 16 | ${PYTHON_PN}-ctypes \ |
| 17 | ${PYTHON_PN}-mmap \ |
| 18 | ${PYTHON_PN}-logging \ |
| 19 | " |
| 20 | |
| 21 | BBCLASSEXTEND = "native" |