Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 1 | SUMMARY = "Audio format Conversion library" |
| 2 | DESCRIPTION = "Library for reading and writing files containing sampled \ |
| 3 | sound (such as MS Windows WAV and the Apple/SGI AIFF format) through \ |
| 4 | one standard library interface." |
| 5 | HOMEPAGE = "https://libsndfile.github.io/libsndfile/" |
| 6 | AUTHOR = "Erik de Castro Lopo" |
| 7 | DEPENDS = "flac libogg libvorbis" |
| 8 | SECTION = "libs/multimedia" |
| 9 | LICENSE = "LGPL-2.1-only" |
| 10 | |
| 11 | SRC_URI = "https://github.com/libsndfile/libsndfile/releases/download/${PV}/libsndfile-${PV}.tar.bz2 \ |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 12 | file://noopus.patch \ |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 13 | " |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 14 | UPSTREAM_CHECK_URI = "https://github.com/libsndfile/libsndfile/releases/" |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 15 | |
| 16 | SRC_URI[md5sum] = "3f3b2a86a032f064ef922a2c8c191f7b" |
| 17 | SRC_URI[sha256sum] = "a8cfb1c09ea6e90eff4ca87322d4168cdbe5035cb48717b40bf77e751cc02163" |
| 18 | |
| 19 | LIC_FILES_CHKSUM = "file://COPYING;md5=e77fe93202736b47c07035910f47974a" |
| 20 | |
| 21 | CVE_PRODUCT = "libsndfile" |
| 22 | |
| 23 | S = "${WORKDIR}/libsndfile-${PV}" |
| 24 | |
| 25 | PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'alsa', d)}" |
| 26 | PACKAGECONFIG[alsa] = "--enable-alsa,--disable-alsa,alsa-lib" |
| 27 | PACKAGECONFIG[regtest] = "--enable-sqlite,--disable-sqlite,sqlite3" |
| 28 | |
| 29 | inherit autotools lib_package pkgconfig multilib_header |
| 30 | |
| 31 | do_install:append() { |
| 32 | oe_multilib_header sndfile.h |
| 33 | } |