Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 1 | SUMMARY = "A library for using PKCS" |
| 2 | DESCRIPTION = "pkcs11-helper is a library that simplifies the interaction with PKCS \ |
| 3 | providers for end-user applications using a simple API and optional OpenSSL \ |
| 4 | engine. The library allows using multiple PKCS enumerating available token \ |
| 5 | certificates, or selecting a certificate directly by serialized id, handling \ |
| 6 | card removal and card insert events, handling card ie-insert to a different \ |
| 7 | slot, supporting session expiration and much more all using a simple API." |
| 8 | |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 9 | HOMEPAGE = "https://github.com/OpenSC/pkcs11-helper" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 10 | SECTION = "Development/Libraries" |
| 11 | |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 12 | LICENSE = "GPL-2.0-only & BSD-3-Clause" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 13 | LIC_FILES_CHKSUM = " \ |
| 14 | file://COPYING;md5=30f10d22cfb1ba98ccd714a41ad3311a \ |
| 15 | file://COPYING.GPL;md5=8a71d0475d08eee76d8b6d0c6dbec543 \ |
| 16 | file://COPYING.BSD;md5=66b7a37c3c10483c1fd86007726104d7 \ |
| 17 | " |
| 18 | SRC_URI = "git://github.com/OpenSC/${BPN}.git;branch=master;protocol=https" |
| 19 | |
| 20 | S = "${WORKDIR}/git" |
| 21 | # v1.27 |
Andrew Geissler | d583833 | 2022-05-27 11:33:10 -0500 | [diff] [blame^] | 22 | SRCREV = "2306f896c2f3c147792300155316fd65825aabad" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 23 | |
| 24 | UPSTREAM_CHECK_GITTAGREGEX = "pkcs11-helper-(?P<pver>\d+(\.\d+)+)" |
| 25 | |
| 26 | DEPENDS = "zlib nettle gnutls gmp openssl nss nspr" |
| 27 | |
| 28 | inherit autotools pkgconfig |
| 29 | |
| 30 | EXTRA_OECONF = "--disable-static" |