Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 1 | SUMMARY = "Basic desktop integration functions" |
| 2 | HOMEPAGE = "https://www.freedesktop.org/wiki/Software/xdg-utils/" |
| 3 | DESCRIPTION = "The xdg-utils package is a set of simple scripts that provide basic \ |
| 4 | desktop integration functions for any Free Desktop, such as Linux. \ |
| 5 | They are intended to provide a set of defacto standards. \ |
| 6 | The following scripts are provided at this time: \ |
| 7 | xdg-desktop-icon \ |
| 8 | xdg-desktop-menu \ |
| 9 | xdg-email \ |
| 10 | xdg-icon-resource \ |
| 11 | xdg-mime \ |
| 12 | xdg-open \ |
| 13 | xdg-screensaver \ |
| 14 | xdg-terminal \ |
| 15 | " |
| 16 | |
| 17 | LICENSE = "MIT" |
| 18 | LIC_FILES_CHKSUM = "file://LICENSE;md5=a5367a90934098d6b05af3b746405014" |
| 19 | |
| 20 | SRC_URI = "http://portland.freedesktop.org/download/${BPN}-${PV}.tar.gz \ |
| 21 | file://0001-Reinstate-xdg-terminal.patch \ |
| 22 | file://0001-Don-t-build-the-in-script-manual.patch \ |
| 23 | " |
| 24 | |
| 25 | SRC_URI[md5sum] = "361e75eb76c94d19f6f4f330d8ee626b" |
| 26 | SRC_URI[sha256sum] = "951952e2c6bb21214e0bb54e0dffa057d30f5563300225c24c16fba846258bcc" |
| 27 | |
| 28 | UPSTREAM_CHECK_REGEX = "xdg-utils-(?P<pver>((\d+[\.\-_]*)+)((rc|alpha|beta)\d+)?)\.(tar\.gz|tgz)" |
| 29 | |
| 30 | # Needs brokensep as this doesn't use automake |
| 31 | inherit autotools-brokensep distro_features_check |
| 32 | |
| 33 | # The xprop requires x11 in DISTRO_FEATURES |
| 34 | REQUIRED_DISTRO_FEATURES = "x11" |
| 35 | |
| 36 | DEPENDS = "xmlto-native libxslt-native" |
| 37 | RDEPENDS_${PN} += "xprop" |