Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | # |
| 2 | # Copyright (C) 2013 Wind River Systems, Inc. |
| 3 | # |
| 4 | # This program is free software; you can redistribute it and/or modify |
| 5 | # it under the terms of the GNU General Public License version 2 as |
| 6 | # published by the Free Software Foundation. |
| 7 | # |
| 8 | SUMMARY = "Frequency and Idle power monitoring tools for Linux" |
| 9 | |
| 10 | DESCRIPTION = "The turbostat tool allows you to determine the actual \ |
| 11 | processor frequency and idle power saving state residency on supported \ |
| 12 | processors." |
| 13 | |
| 14 | LICENSE = "GPLv2" |
| 15 | LIC_FILES_CHKSUM = "file://../COPYING;md5=bbea815ee2795b2f4230826c0c6b8814" |
| 16 | COMPATIBLE_HOST = '(x86_64.*|i.86.*)-linux' |
| 17 | COMPATIBLE_HOST_libc-musl = "null" |
| 18 | |
| 19 | SRC_URI += "\ |
| 20 | file://COPYING \ |
| 21 | " |
| 22 | |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 23 | PACKAGE_ARCH = "${MACHINE_ARCH}" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 24 | DEPENDS = "virtual/kernel" |
| 25 | |
| 26 | # This looks in S, so we better make sure there's |
| 27 | # something in the directory. |
| 28 | # |
| 29 | do_populate_lic[depends] = "${PN}:do_configure" |
| 30 | |
| 31 | |
| 32 | EXTRA_OEMAKE = '\ |
| 33 | CC="${CC}" \ |
| 34 | 'CFLAGS=-Wall -I${STAGING_KERNEL_DIR}/arch/x86/include/uapi ${LDFLAGS}' \ |
| 35 | ' |
| 36 | |
| 37 | # If we build under STAGING_KERNEL_DIR, source will not be put |
| 38 | # into the dbg rpm. STAGING_KERNEL_DIR will exist by the time |
| 39 | # do_configure() is invoked so we can safely copy from it. |
| 40 | # |
| 41 | do_configure_prepend() { |
| 42 | mkdir -p ${S} |
| 43 | cp -r ${STAGING_KERNEL_DIR}/arch/x86/include/asm/msr-index.h ${S} |
| 44 | cp -r ${STAGING_KERNEL_DIR}/arch/x86/include/asm/intel-family.h ${S} |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 45 | cp -r ${STAGING_KERNEL_DIR}/include/linux/bits.h ${S} |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 46 | cp -r ${STAGING_KERNEL_DIR}/tools/power/x86/turbostat/* ${S} |
| 47 | cp -r ${WORKDIR}/COPYING ${S} |
| 48 | } |
| 49 | |
| 50 | do_compile() { |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 51 | sed -i 's#<linux/bits.h>#"bits.h"#' msr-index.h |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 52 | sed -i 's#MSRHEADER#"msr-index.h"#' turbostat.c |
| 53 | sed -i 's#INTEL_FAMILY_HEADER#"intel-family.h"#' turbostat.c |
| 54 | sed -i 's#\$(CC) \$(CFLAGS) \$< -o \$(BUILD_OUTPUT)/\$@#\$(CC) \$(CFLAGS) \$(LDFLAGS) \$< -o \$(BUILD_OUTPUT)/\$@#' Makefile |
| 55 | oe_runmake STAGING_KERNEL_DIR=${STAGING_KERNEL_DIR} |
| 56 | } |
| 57 | |
| 58 | do_install() { |
| 59 | oe_runmake DESTDIR="${D}" install |
| 60 | } |